Path to Convert

I'm running omeka under Leopard and on my settings, I have /opt/local/bin for the location of convert. When I test, it fails.

edbusch$ ls -la /opt/local/bin/convert
-rwxr-xr-x 2 root admin 9132 Aug 19 09:35 /opt/local/bin/convert

Any ideas?

If you create an item in Omeka and upload an image file, does it create derivative images, a square thumbnail on the items/show page? If so, it could be that you have a similar issue that I also have on my own personal set-up. I run Omeka locally on my Mac too, and like you, the test for the Path to Convert fails for me, even though it creates derivative images fine. To be honest, we're not sure why the test fails even if the path to ImageMagick is correctly entered in the settings and Omeka can create derivative images. And, as far as I know, you're the first person besides me to report this issue on a Mac.

If, however, your Omeka installation is not creating derivative images, then there's a bigger issue involved and we'll need to explore further.

Actually, I haven't tried beyond the test in settings yet. I'll let you know if I see a problem down the line.



My installation is not creating derivative images of uploaded files (folders fullsize, thumbnails and square_thumbnails are empty). These folders are with changed CHMOD to 777, after 755 didn't work. My ImageMagic path is properly configured and when I test it it says "Works" (when I tried to put /convert at the and of the path the system displayed error message).

Any suggestions?

When you upload a file and derivative images aren't created, what error message is flashed on the screen? Have you tried uploading different types of files?


Sorry for this late reply.

Well there is no error message when I upload file. 404 error is displayed when I try to open that file, clicking on the link provided at "Still Image Item Type Metadata", as in this example

That link is showing the name of the file ifla2009-2.jpg, but the address bar of the error page is showing some ifla2009-2_6273f1f8a6.jpg file. I assume it must be derivative image, never created.

I also uploaded an mp3 file and everything went well (it opens when clicked).

After searching the forum I've realized what you meant with "error message". I uploaded another still image to repeat the whole process and now my error log file is saying:

2009-09-27T22:56:40+02:00 DEBUG (7): Could not retrieve element text for the element named "IPTC Array"

Hope this will help.

Hi Bogdan,

This is a bug that has been fixed ( for the upcoming 1.1 release of Omeka. Once it's released, please test it out and let us know that you're no longer having this problem.


Hi Dave,

I've installed Omeka 1.1 and tried it, but after adding my first item I've got this line:

Error:An item has not been set to be displayed on this theme page! Please see Omeka documentation for details.

I have changed default and Berlin theme, but the result is the same. I didn't change any of the default configuration except adding Berlin theme.

Could you share a link to the page where this error message is being displayed? Have you tried re-uploading the file since you've upgraded to Omeka 1.1?

Hi Dave,

here is the link

I've upgraded Omeka and database to version 1.1

That error emerges when item is uploaded. After deleting item everything is working again, but without content. My fullsize, thumbnails and square_thumbnails folders are empty.

I've noticed that ImageMagic path works when I test it, but after testing it there is a display of an error (on admin page, just below ImageMagic test field and button):
"Warning: exec() has been disabled for security reasons in /home/cacakdis/public_html/test/application/controllers/SettingsController.php on line 97"

That line of code says:
exec($fullPath, $output, $returnCode);

Hi Bogdan,

Omeka requires that you can run exec on your server in order to generate derivative images using ImageMagick. You can see justification for why we use exec on this post from the developer mailing list: I'd suggest contacting your server administrator to see if you can have this enabled, since Omeka requires it to generate derivative images.


Server administrator responded that exec and shell_exec functions can not be enabled because of security reasons. BTW, our hosting company is located in Serbia but they are using (reselling) servers in Dallas.

So, if exec must be enabled I suppose this is the end for 1.1 version for us, for now. On the other hand, 1.0beta version at doesn't have this problem, although it's using the same server. But I don't want to work with the old version, which is also a beta. Is there any way to solve this situtation?

Hi bogdan,

I'll bring this up with a few of our developers, and see if there's a possible workaround. I'll let you know something as soon as I do.


Hi Jeremy,

Is there any progress with this exec issue in 1.1 version?

Unfortunately, to use image magick or background processes in Omeka 1.1+, your hosting plan will need to allow you to run exec. We don't know of any work around for this.