oops 403 error when adding item using contributor plugin

I installed the contributor plugin using the directions in the screencast for the contributor plugin.

I get the dialog box for contributing an item, fill it out, select the file to add, and agree to the consent form. Then, I get a message that says "oops sorry, this page does not exist. Check your url or send us a note."

I receive an email as the administrator indicating that a contribution was made, with a url. When I select the url, I get a 403 error.

Any tips on what to troubleshoot?

I can add items to the archive using a standard contributor login.


Hi kwalsh,

Have you read through the string of discussions about the contribution plugin on the forums? Others were having similar issues earlier this year, see:

Are you using the version of the plugin currently available in the directory? http://omeka.org/files/plugins/omeka-contribution-plugin-0.9.1.zip?

There was also discussion on the dev list, which is open to everyone on Google Groups: http://groups.google.com/group/omeka-dev/browse_thread/thread/474726e83a529a09

Does this help?


I am still having the same issue and have following the directions in the posting to delete the instances of two 'contribution' text strings - See

I have a completely fresh installation of omeka with a fresh copy of the contributor plugin.

I have deleted the occurrence of the text string 'contribution' even though there is only one occurrence in the add.php file.

I still get the message
Sorry, this page doesn't exist. Check your URL, or send us a note

I must be missing something very simple.

Can someone please post their working configuration files so I can see an example of what works.


Hi, what is the URL for which you are getting the 403 error?


The sites that I am working with are that exhibit the same problems are -




hpchistory.org is a completely fresh install of omeka

both sites are hosted by dreamhost

kevin walsh

more detail
looked at all of the cases indicated in the links you sent me. See below.

Based upon what I see in the posting, it is not clear that there is a fix. For some people the plugin works; for some not. Your reply to Tonu three months ago indicated you all were waiting for the plugin developer to return from vacation. Tonu's sample web site at GMU currently displays the same error that others are reporting. I am getting the same error on my omeka based archives. www.scxyhistory.org and www.netabolic.org

I created a completely new site using the freshest omeka and contributor plugin and I get still get the same error others have reported. hpchistory.org
Go to www.hpchistory.org/contribute and try to contribute something, and you will see exactly what happens.

I verified that the add.php file does not have two occurrences of the text string "contribution" according to the advice of Dave Lester described here-
See http://groups.google.com/group/omeka-dev/browse_thread/thread/474726e83a529a09

The problem occurs even when I delete the single occurrence of the "contribution". This makes me think the source of the problem is not the add.php file.

Is it possible to post the sections of the necessary files on a omeka based archive that works and does not exhibit this problem?

I may be doing something wrong that is very simple.

The correct URI should be contribution/thankyou instead of contribution/contribution/thankyou . That would take you to the correct thankyou page. That URI is located in the controllers/ContributionController.php file, in a function called submitAction(). You could try tweaking that to see if it fixes it.

Also, the item is being added to the database properly, but you also need to set the item as public via the admin interface before the link in the email will actually work.

Hope that helps.