Omeka/MAMP Installation Issues

I'm trying to install Omeka locally using the MAMP environment on my MacBook running 10.6.4. MAMP is installed correctly and the Omeka files seem to be configured properly.

When I go to run the installer with MAMP running as PHP 5.3.5 I get the following error:

Fatal error: Maximum execution time of 30 seconds exceeded in /Users/LaFlash/TNG/omeka/application/libraries/Zend/Validate/StringLength.php on line 236

I was able to find someone that had the same issue in one of the other forums, which was solved by changing to PHP 5.2.17. However, when I make this change I receive the following "installation warning": "fileinfo" module not loaded.

Does anyone have thoughts on how to resolve this? I'm good enough with this stuff to get the job done, but not a pro by a long shot. Any help would be appreciated.


This is a bug in the specific PHP 5.3 version (I believe it's 5.3.5) used by the latest versions of MAMP.

There's a thread on the MAMP forums about this, where at least some people report success by reverting to a previous MAMP version.

Omeka will work fine under either PHP 5.2 or 5.3. The warning you're seeing with 5.2 is telling you that you don't have a feature of 5.3 that Omeka uses for improved file type detection, but you can still run Omeka on 5.2.17 despite the warning.

However if you switch to PHP in MAMP 1.9.6 to install Omeka 1.4 you get an error on the install page saying:

"fileinfo" module not loaded. Without the fileinfo module loaded into PHP, the content type and encoding of uploaded files about cannot be read. The installer will disable file upload validation.

I'm going to revert back to MAMP 1.9.4 to see if this avoids the problem. If successful (in installing v1.4) I'll post back to this thread.

Using MAMP 1.9.4 (w/ default PHP 5.3.2) solved the problem. I was able to install v1.4 with no issues.

Thought I'd share in case others are having the same issue: I encountered a similar problem on OS X 10.6.7. Moving to MAMP's most recent update (2.0.1, updated 7/15/2011) and switching PHP to 5.2.17 solved the issue for me (combining earlier versions of MAMP and PHP had not).

Thanks for sharing.

Just to clarify, the problem was still there if you used the bundled PHP 5.3.6 from MAMP? This is an upgraded version from the older 1.9 MAMP releases, and I had hoped it would resolve this issue with MAMP without forcing users to fall back to PHP 5.2.

Hi John,

I wanted to chime in that I am using MAMP 2.0.1, released 7/15. I also have to use PHP 5.2.17 to run my Omeka installation. Here is some info from my error log.

[20-Jul-2011 11:20:16] PHP Catchable fatal error:  Argument 1 passed to Omeka_Core_Resource_Options::_convertMigrationSchema() must be an array, null given, called in /Applications/MAMP/htdocs/fourone/application/libraries/Omeka/Core/Resource/Options.php on line 49 and defined in /Applications/MAMP/htdocs/fourone/application/libraries/Omeka/Core/Resource/Options.php on line 79
[20-Jul-2011 11:25:43] PHP Warning:  PHP Startup: Unable to load dynamic library '/Applications/MAMP/bin/php/php5.3.6/lib/php/extensions/no-debug-non-zts-20090626/' - dlopen(/Applications/MAMP/bin/php/php5.3.6/lib/php/extensions/no-debug-non-zts-20090626/, 9): Library not loaded: /Applications/MAMP/Library/lib/libltdl.7.dylib
  Referenced from: /Applications/MAMP/bin/php/php5.3.6/lib/php/extensions/no-debug-non-zts-20090626/
  Reason: Incompatible library version: requires version 11.0.0 or later, but libltdl.7.dylib provides version 9.0.0 in Unknown on line 0

There's a slightly more up-to-date thread on the MAMP forums, but it doesn't sound like there's been any movement on fixing the "Maximum execution time of 30 seconds..." iconv bug that people are seeing with 5.3.

This other error message, about mcrypt, seems to be different, but still seems to be a MAMP issue, not an Omeka issue.

MAMP v2.02 with PHP 5.3.6. seems to work fine. The MAMP developers noted in their forums that the iconv bug was fixed.

Thanks for the update.

Yes, it does appear from several postings on the MAMP forums that this bug is fixed in MAMP 2.0.2 (and the fix will not be backported to the 1.x series).