Omeka_File_Derivative_Exception and escapeshellarg

After a long period without uploading any new files, I have tried to add some new items to my Omeka site, but can't add any images. When I try I recieve the following error "Omeka_File_Derivative_Exception Something went wrong with image creation. Please notify an administrator."

After some experimentation I discovered the error was being caused by the escapeshellarg function, which appears to be returning NULL regardless of it's input. This means the command being sent to exec is missing the file names and the resize size! The question is, what went wrong and how do I fix it?


By the way, I am runnign Omeka Version 1.5.3 and PHP 5.3.27

Could you or your host have somehow added escapeshellarg to PHP's disabled functions list? Generally, calling a disabled function results in a NULL return.

The other thing about escapeshellarg is that it's dependent on your system locale to decide which characters are valid ones. If your system locale's gotten reset or unset somehow, it could cause problems with this function.

At any rate, it sounds like some sort of server or configuration change/problem, rather than something at the Omeka level.

Yes, escapeshellarg was disabled and showed up in the list of disabled functions when I ran phpinfo(). (I had no idea there was such a list!) Now to figure out why it was added to the list and how I can get it changed!