omeka setup problems & guide

I have been trying to install omeka off and on for several weeks to evaluate it for an organisation I am involved with. Regrettablly I find the install instructions woefully inadequate for a new user.

The platform is Mageia 4 64bit, apache 2.4.7, mariadb server version 5.5.43, php 5.5.26, zend 2.5.0 and I am using your instructions for installation of Omeka 2.3 under fedora.

Starting with index.php I continue to get the msg 'mod_rewrite is not installed' although the module is compiled in according phpinfo, and .htaccess contains the line 'RewriteEngine on'. For now I have given up on this error.

From the web I noted that installation can be done from ./install/install.php so tried it. After reading the install notes and filling in all required fields I could not find a button for 'Install', 'Submit" or any other instuction on how to proceed. Only by chance I found yesterday that the enter button must be pressed for each individual field. Your form and instructions are sadly lacking in this respect. This time when I entered my password it was rejected 4 times and only accepted after I entered my email address.

Now, when I go to localhost/omeka/ I get a page headed 'Okekatest'. Clicking on 'Browse Items' or 'Browse Collections' produces a 404 error. Is there a description of this page?

Using the instruction in Documentation I went to /omeka/admin. After pressing Enter, I was transferred to /omeka/admin/users/login with a 404 error. On checking the directory structure I found login under /omeka/admin/themes/default/users/login.php.

As I am now thoroughly confused, could you please give me some guidance on these matters


Getting a bunch of 404 errors almost always means that you don't have mod_rewrite set up correctly. The most common cause is that you have AllowOverride off in your Apache server configuration so the .htaccess file is being ignored.

As for problems with the installation form, it's definitely not necessary to press Enter for each field, and there should just be a button at the bottom of the form to submit it. Not sure what's going on there.

thanks for this information

Thank you John and Kelly. I will work through mod_rewrite and try again. What is the problem for the varying login directory paths I found?, see my 2nd last para above

I appear to have the mod_rewrite problem fixed now.

Logging in has got me completely beaten. I go to this site 'http://localhost/omeka-2.3/admin/index.php/users/login' and enter the same username and password as set up in db.ini but it is rejected and returns me to a blank login screen hidden behind an error screen listing almost entirely html errors in acss file.

Could you please help me. TIA

BTW all files have at least rw access.

The login information in db.ini is only used to connect to the MySQL database. It has no bearing on the accounts created in Omeka. You should be logging in with the username and password you chose during installation.

If you're getting an error screen, it would be helpful if you could copy the output here.

Thanks for your reply.

Tried login & password from mysql.users and from omeka_db.user. Neither worked.

Following is a sample of error messages I am getting each time I try to login.

[31/07/15 21:32:05] CSS - http://localhost/omeka-2.3/admin/themes/default/css/skeleton.css
Linked-in stylesheet
Invalid value for property: zoom
Line 376:
zoom: 1; }
[31/07/15 21:32:05] CSS - http://localhost/omeka-2.3/admin/themes/default/css/style.css
Linked-in stylesheet
Invalid value for property: clip
Line 103:
[31/07/15 21:32:05] CSS - http://localhost/omeka-2.3/admin/themes/default/css/style.css
Linked-in stylesheet
Unrecognized function
Line 344:
background: -moz-linear-gradient(top, #A4C637, #75940A);
[31/07/15 21:32:05] CSS - http://localhost/omeka-2.3/admin/themes/default/css/style.css
Linked-in stylesheet
Invalid value for property: background
Line 344:
background: -moz-linear-gradient(top, #A4C637, #75940A);

Hello Again.
As well as the css errors for which a sample is shown above, I am still unable to log in to omeka.

In order to try to sort the problem I have set my mysql user and login to the same as for omeka_db with the same in db.ini. The omeka/okekatest screen goes blank as soon as I click login, but there are no messages.

Errors are generated from ...users/login being HTML style attributes with invalid function or attributes.

Could you help me please.

Messages above now obsolete. I never got that version to run nor a reply to my last request! so gave up.

I have now downloaded Omeka-2.4.1, unpacked and installed it. Database is set up. Install completed and I get a screen saying 'SUCCESS! Omeka is installed'.

The problem now is that there is no response from the 2 buttons 'Public Site' & 'Admin Dashboard".
The system just hangs!

Starting again but going to /Admin takes me back to the installation confirmation screen.
Can you help please.