[Omeka 2.1.1] No results for simple (keyword) search in admin mode.

Hi Folks,

I'm getting a "zero results returned" message for simple keyword searches when I'm logged into the administrative side of my Omeka 2.1.1 instance. However, when I perform the same search in the keyword field of the Advanced Search (Items only) I get results.

Any thoughts?

I'm having similar trouble. Since I upgraded to 2.0.4, keyword searching isn't working at all. I have used the "Index Records" button in the settings to re-index, but still nothing. Unlike Tom, I can't even get the keyword search to work within the advanced search. However, if I use advanced search to search in specific fields, I do get the expected results.

Any idea what I should be looking at to figure out the problem?

Thank you!

At least as far as the Items-specific keyword search is concerned, I think you're describing different situations.

Version 2.1 fixed a few reported problems with the advanced Items search, and I believe this is one of them.

As for the simple sitewide search, that's really independent of the Items search. That search works a different way and has some different restrictions about things like the minimum length of the keywords (very short ones are ignored) and whether partial keywords get matched (they don't).

I'll try to upgrade to 2.1 and I'll report back. Thanks!

OK - I've upgraded to 2.1.2, and now I'm getting the exact same results as Tom - keyword search from the search box doesn't work, but the keyword search in advanced search does. So, a little improvement!

Can you elaborate about the fact that partial keywords don't get matched in the simple sitewide search? What constitutes "partial"?

Basically, the searches I'm trying are all ones that worked with the simple sitewide search in 1.0, and I'd love to get them working in 2.0. I'm hesitant to upgrade any of my other sites to 2.0 until this is resolved.

Any help is greatly appreciated!

+1 for this, I'd like a bit more info on partial/short keywords.

It seems after some further testing that any content/items I have created after the upgrade to 2.1.1 are available from the sitewide search, whereas preexisting items that came across in the upgrade aren't coming up.
Perhaps there's an indexing process that hasn't occurred in the upgrade?

Happy to supply any logs or screenshots to help troubleshoot further.

Okay, sorry about this - I've just discovered that I hadn't ticked all of the record types in

After doing that, and triggering a reindex my issue has been resolved.

Sheepishly yours,


Well, I have ticked them all off, and triggered the re-indexing - a couple of times - and still no luck. Is there any way of telling if the re-indexing really happened? How long should it take? Are there settings on my server that would affect the indexing?


Hello, anyone come up with anything for this?

I have a new install of 2.1.3, and while the indexing under advanced search appears to be working, what John has called the "the simple sitewide search" above isn't working at all, admin or public side. I have ticked and unticked all the various boxes in all the combinations I can think of and tried all the words currently added to items with the only result being "Your query returned no results."

Anyone know where to go from here?
Many thanks!

Sorry, forgot to say I have also repeatedly rebuilt the index, with no errors in the error log.

And sorry for a second time, adding the info that if I look at the omeka db from within phpMyAdmin, i can see the terms I'm looking for inside the table 'omeka_search_texts', which makes it look like MySql is doing its job to at least this extent. Any idea what magic needs to be done to get the simple search to see these terms?

So, the search_texts table appears to contain the texts you're hoping to search on?

That's basically all the "indexing" is supposed to accomplish.

Could you give any short examples of text in your items and the strings you're using to search that aren't working? The MySQL fulltext search can be a little bit quirky, and it's possible that everything's fine and just some little changes to your search terms will work.

Hi John, thanks for coming back.

The text table reports that it contains the texts I'm searching on. I'm searching on the exact same keywords in the table, case, number, everything in exact agreement. I'm not offering it any opportunity for mistakes, truncations, stopwords or short words. Words include 'samurai', 'warriors' 'print', 'paper'. Nothing doing.

The same thing happened with another trial install of 2.1.2 on another machine - any ideas as to what I might try? Thanks again for the input.

Ah, one other thing: we're not talking about an extremely small number of items, like 1 or 2, right?

That's one of the other unexpected quirks of the MySQL system: it excludes terms that appear in 50% or more of the rows indexed, so if you have 1 or 2 items, or a great many items with the same terms, stuff sometimes gets excluded.

Do any of the "advanced" choices for the sitewide search make a difference, like using the boolean or exact match options?

Ah! Could be that - yes, only a tiny number of items added so far. I'll add some more, and report back. Thanks for pursuing this and hitting me with the clue-stick!

Thanks to John for resolving this. His advice above is right, once a sufficient number of items is added to the database, MySql sees the index terms and works as expected. This is not an Omeka issue, in fact, but a MySql issue. My mistake for breaking off to 'solve' a problem that is merely a minor peculiarity of the underlying database.