OAI repository error

I am trying to make my digital library OAI-compliant, but everytime I query it, I get the following error message: "There is no element named 'Format'". Help? I don't know if that means it's not mapping correctly, or it's just not seeing the format field, which does exist in my library.


Do you mind posting your OAI URL? If you don't want to make it public yet, you can email it to me: outreach at omeka dot org. We'll try it and post back to the forums.

By any chance, have you made any changes to the elements/fields in the database directly?

Do you have any update on the OAI Repository plugin? I am using 1.2 and getting badVerb error. "Harvestable Omeka OAI sets" at http://omeka.org/codex/Harvestable_Omeka_OAI_sets do also produce same error message.


Are you clicking on the link generated for your Omeka site (or the examples you linked to) from the Repository plugin interface? Or, are you entering that URL in Omeka's OAI-Harvester plugin interface ( or other software)to harvest one of those sample repositories?

I've tested these plugins on 1.2 installations and I've had success harvesting the data.

Can you tell me more about what you are doing specifically?

I have been clicking the link generated from the repository plugin interface.

Just tried to link to harvest records and it worked. Thanks.