OAI repository does not return records when harvested

Hi there,

I have a local instance of Omeka installed on my Mac, and I'm trying to harvest the records out of it. I have the repository plugin set up (although maybe not correctly?) but when I click on the provided link, I get the following:

<OAI-PMH xsi:schemaLocation="http://www.openarchives.org/OAI/2.0/ http://www.openarchives.org/OAI/2.0/OAI-PMH.xsd">
<error code="badVerb"/>
<error code="badArgument">Missing required argument verb.</error>

I've also tried using the harvester plugin, which states that the harvest is starting, but never actually does anything. I've also tried the harvester in MarcEdit, which says that no records were returned. Any suggestions would be helpful.



I'm quite sure that I understand your harvesting process. If you have a local installation, then you can't access that site unless you are on your laptop, because it's not actually available on the web. Are you trying to harvest your laptop's site from a different Omeka site that is on a web server?

When harvesting records from another Omeka site, be sure the base URL looks like this: http://archiveyouareharvesting.org/oai-pmh-repository/request

Do you have the most recent versions of Omeka and the OAI-PMH harvester running?

Thanks for the response! I was trying access the site data from my laptop. The repository and Omeka versions are the latest releases. I realize now I probably don't want to use the Harvester - basically, I really just want the Dublin Core records out of the local Omeka site so I can transform them into MODS/METS records and use them on my non-Omeka site.

Am I right in thinking that clicking on the http://localhost/oai-pmh-repository/request link on the local OAI_PMH Repository page (in the admin section) should call up the DC xml data?

What about using one of the many data outputs (available at the bottom of the admin/items screen)?

dcmes-xml | json | omeka-json | omeka-xml | rss2

Beautiful! I don't regularly work with Omeka, so I had no idea those were there. Thank you so much!