OAI-PMH harvester / version 2.3.1


May the 2.3.1 update have an influence (a bad one, I mean) on the OAI-PMH harvester plugin ?

I get an error "Omeka has encountered an error" .. and cannot get any info in the logs.


What source(s) are you harvesting from, so we can try and duplicate the error?


I tried several, but a light one is

(you can take the first set)

It works with another install of Omeka I work with which version is 2.3

Which version of the Harvester are you using?


On my test install I'm running Omeka 2.3.1 and OAI Harvester 2.0.1 and I'm not getting any errors.

When are you getting the errors? After you click View Sets or after you click Go for a specific set?

What other plugins do you have installed?

No other plugin is installed.
The error is after I click "Go".
Hum ... it is strange.

Have you tried completely uninstalling and then reinstalling the plugin?

I just did.
I had no change.

But I just noticed a trace after having activated a lot of trace, which make me think that the installation of the newer version is not 100% the same as the one that was done with the 2.3 version

"2015-10-26T15:36:29+01:00 DEBUG (7): INSERT INTO omeka_oaipmh_harvester_harvests (id, collection_id, base_url, metadata_prefix, set_spec, set_name, set_description, status, status_messages, resumption_token, initiated, completed, start_from) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?) ON DUPLICATE KEY UPDATE id = LAST_INSERT_ID(id), collection_id = ?, base_url = ?, metadata_prefix = ?, set_spec = ?, set_name = ?, set_description = ?, status = ?, status_messages = ?, resumption_token = ?, initiated = ?, completed = ?, start_from = ?
2015-10-26T15:36:29+01:00 ERR (3): exception 'RuntimeException' with message 'Le chemin vers PHP () tel qu'il est configuré est invalide.' in /store/www/elutrin.sciencespo.fr/application/libraries/Omeka/Job/Process/Dispatcher.php:115"

I still have this exception on the PHP path .. did anyone get a solution ?

Omeka 2.3.1
Php 5.5.29
OaipmhHarvester 2.0.1

However, Omeka doesn't seem to find PHP.

2015-11-06T16:08:05+01:00 ERR (3): exception 'RuntimeException' with message 'Le chemin vers PHP () tel qu'il est configuré est invalide.' in /store/www/elutrin.sciencespo.fr/application/libraries/Omeka/Job/Process/Dispatcher.php:115

Thank you