OAI-PMH Harvester not working on Omeka 2.1.4

Hello! I've got an interesting one here that I can't seem to resolve. I have two instances of Omeka running on the same server. They share the same instance of Apache and PHP. The problem is that the OAI Harvester plugin works in one but not in the other. The version of the plugin is the same in both instances (version 2.0), but the version of Omeka differs. The plugin works in Omeka version 2.0.2, but it does not work in Omeka version 2.1.4.

Alright, so here's what happens. I enter in the base URL and it pulls up the collection list just fine. I push 'Go' on the desired collection and the harvest will show up as 'In Progress', but the harvest never finishes and there aren't any errors anywhere. I've checked the Apache error logs and I've turned on any and all logging for PHP and Omeka and no errors get logged. I've tried reinstalling the plugin to no avail. I double checked database and file permissions and all seems to be in line. The Status Message also shows up blank on that harvest, so it's not helpful either.

Any ideas on where to look? Was something about item creation/importing changed in 2.1.4 that renders the OAI Harvester out of date?

Thanks in advance

I don't see any problem with the harvester on version 2.1.

What URL/set are you trying to harvest from? It's possible the problem only crops up with particular kinds of data.

Thanks for the reply. I've primarily been using http://digital.lib.usu.edu/cgi-bin/oai.exe/request as the URL, but I have also tried a couple other third party ones with no luck. This same URL works fine in the Omeka 2.0 version, but not in 2.1.

For future reference, editing the config.ini file and changing the following solved the issue:

jobs.dispatcher.longRunning = "Omeka_Job_Dispatcher_Adapter_Synchronous"

It is still odd that one instance works and the other doesn't considering they both run on the same instance of PHP. But oh well, at least it is working now.

Another possibility that could explain what you are seeing is that the

background.php.path = ""

setting in config.ini is different for the two sites. Probably one is the default empty, and the other has filled in a path?

Thanks. Yeah, I had checked that setting first when I first noticed the problem. At that time, both instances had an empty value. I tried filling in the path for the broken instance but that didn't fix it.

Still scratching my head on this one, but like I said, at least I have a solution that works for now. Appreciate the help.