not able to view uploaded files


I have got a problem with the 'contribution' plugin, it allows me to upload files and documents but it won't allow me to view it, when I make contributions 'public' I get to see the description of the uploaded file and not able to view the file itself. my server admin has PHP 5.2 and ImageMagick installed on a Linux server. am I missing any thing to not be able to view the uploaded files? you can check it out at


Hi, can you verify that the files were actually uploaded? If you have not set proper permissions on the 'archive' directory then the files wouldn't have uploaded properly. This gives a proper error message within the administrative interface, but it might not be apparent when uploading from the contribution plugin.

I can see the files in the 'archive' directory through my c-panel. I guess that proves the files are being uploaded. when I tried to upload from 'archive' in the admin interface I got the error below, even though I could see the title of the file I just uploaded in the list provided, saying that I still can not view the file.

"404: Wha Huh?

You've tried to access a page that does not seem to exist. Sometimes this happens. Below is a quick break-down of the items, collections, and exhibits on this site. If this does not help, try contacting the site administrator."

I have set both permission to 'yes' and it did not make a difference.

'Permission to post the contributor's submission to the public site:'
'Permission to post contributor's submission to the archive:'


What is the URL in your address bar when you see that 404 page? Is it a link that you click on that takes you to that 404 error, or is it when you submit the form? Also, that page sometimes shows up when Omeka has some sort of internal error, so you should activate error logging and then post any errors that you get.


sorry for replying so late, I had other engagements and been really busy,

this is what is shown in the address bar when I see the 404 page, "".

I see this when I click on uploaded items in order to view them.

sorry I could not activate the error logging as I do not know what to change in the application/logs/errors.log in order to change the permission.


You should change permissions on the application/logs/errors.log file in the same way that you originally did that with the archive/ directory when installing omeka. It would be something along the lines of chmod 775 application/logs/errors.log on the commandline, from within your omeka installation. Your server administrator may recommend something different, but something like that should work.

While you're at it, make sure debug.exceptions = true in your application/config/config.ini file. Those two things will let you see errors from Omeka. Then let me know what you see.