NO tags permitted [Solved!]

Hi, thanks for your help.

I'm a new user. After installing Omeka 1.5.3, I tried Omega 2.0 and everything is OK except that it is IMPOSSIBLE to tag the items. The tagging function is out of order. I haven't message in the log file. Nothing in the database. So, probably both in the versions 153 and 2.0.
Do you have a suggestion please ?

Thanks !


EDIT 21:54 : well, it works now, but I absolutely have no idea why!?

When you click the green "Add tags" button, does the tag appear at the bottom of the screen?

It will also help us to know what browser you are using.

Hi, Firefox and Maxthon. Two different computers and locations... All this afternoon... Nothing until 21h54 and now, the tags are in green color... It works!

It works, but I also added the fix saw in the git-hub, posted by patrickmj for autocomplete...

I recently intalled Omeka 2.0 on a fresh server. The browser is Chromium.
I'm dealing with the same issue : I hit the "add tags" button and nothing happens, except a confirmation message, the tag doesn't show.
The other fields work perfectly.
Should I reinstall, upgrade, add a patch, say a prayer at 21:54 ?
Thank you for your time, this is great software.

So, you're clicking the "Add Tags" button and the form immediately submits? That's not what it's supposed to do.

It sounds like you're having some Javascript problem, because the scripts that should run on that page are what would prevent the Add Tags button from submitting like that. Do you see anything in the Console when you're on the edit page (Shift-Ctrl-J)?

Exactly, the "Add Tags" button submits the whole form.

Now I should mention that this computer if off the internet for some reason.
The console basically says it can't find jQuery
Uncaught ReferenceError: jQuery is not defined
after a
I'll copy/paste the console log in my next message.

Is it necessary to run Omeka with a permanet internet access ?
Or at least once ?



Uncaught ReferenceError: jQuery is not defined

Uncaught ReferenceError: jQuery is not defined globals.js

Uncaught ReferenceError: jQuery is not defined


Ah, yes, the Omeka default is to use some fonts and scripts from Google's CDN, so the computer viewing the site has to be online.

You can switch to using local copies in the config.ini file by changing the theme.useInternalAssets setting:

theme.useInternalAssets = true

Thanks John,
You just made my day !