no advanced search option on search bar; 2.0 to 2.2.2 upgrade

A curious thing happened when I did the upgrade from v2.0 to v2.2.2- I lost the advanced search on the search bar, from the back end (admin) site.
I dumped the upgrade from the server; and re-loaded back to v2.0 and the advanced search option is now there.
Any thoughts or ideas?


That is odd. That button on the admin side is generated via some javascript, so it might be something not working in your browser. What browser are you using, and have you looked in other browsers?

I thought about that too, but I recently upgraded another (different) site/database from v2.0 to v2.2.2 and that one doesn't display this particular problem. This is why it's even more odd.
I will re-try the move back to v2.2.2 on the problem site, and see if it generates the same error. I was using Firefox when this particular problem first occurred; so I will also try it in Chrome as well, to see if I get the same issue.

For a visual- the search bar is there but the two control buttons for 'search' and 'advanced search'- which normally appear to the right of the search bar, are not there. Also,the bottom-left underside of the bounding box of the search bar has a green line. ?

Thanks, Patrick.
I was able to trace the problem- partially, to some files I modified way back when- in the themes folder. Because of that, when I moved the earlier themes from v2.0 back into the newer upgrade v2.2.2, the problem occurred. So I simply stayed with the newer themes folder (bundled in v2.2.2), and the problem was solved for the most part.
However, I did do some comparisons between Chrome and Firefox, on two different machines (both MAC). The first one shows fine in Firefox; but not so in Chrome. This machine is running MAC OS v10.6.8
The second machine is newer, running MAC OSv10.7.5; and there were no problems with either Firefox and Chrome.
I ran updates on both machines, so it could be a compatibility problem with Java and older versions of MAC OS

At this point probably more passive information for other users, but hopefully informative for someone who might encounter some problems along the way.
Thanks again for the help!

I'm having the same issue with the Advanced Search link not displaying. I'm on Mac 10.10.2 and have tried Chrome and Firefox. The search box and search button display, but no Advanced Search link.

Looks like those were moved into theme configuration settings. So, click 'configure theme', and look for the "Use Advanced Site-wide Search" checkbox

Is that only true for the theme you're using for the entire Omeka site? The advanced search link isn't showing on any of my exhibits and there's no option to configure that within the exhibit.