Neatline + WMS Layers


I know this is not a new issue, but I'm having trouble adding a WMS layer of a historical map to a Neatline exhibit--and I have not found solutions in the Omeka forum or Neatline documentation.

I have followed Neatline's instructions under option 2 In the past, I've had no trouble doing this, so I'm wondering what might be different (either on my end or on Omeka's).

The problem occurs when I try to add a WMS layer in the Exhibit Settings. When doing this, I put in the following formula for the WMS address: I then enter only the name of the layer in WMS Layer. When I save, I get a blank window where the map should be overlaying a base layer:

I have also tried this formula:

I've read through & tried suggestions in forum topics like this one:

(Even switched back to EPSG:900913 to try.)

I also tried other layers known to work that had been uploaded to a GeoServer previously.

Nothing has worked.

What does work is adding the WMS layer to a Record within the exhibit, and then everything works as it should. This is fine for now, but it's not really the best solution--especially if in future I want to a single overlay for the whole exhibit over which I can add other overlays within Records.

I will add that, in the end, the layer was projected with EPSG:3857 -- WGS84 Web Mercator and then Force declared in the GeoServer.

Any advice is much appreciated.

Thank you,


Hi Hannah,

Were you able to get this to work? I too am encountering trouble with WMS Layers in Neatline.

Thanks! Jon

Hi Jon,

No, not yet. I've been meaning to return to it and try again using a fresh instance and different overlay. I do know that you can insert overlays within records, and they work just fine.


Hi Jon,

Sorry you're having an issue with this. One real quick thing to try is to force this image to retroject in 4326. If that doesn't work, we built a tool that runs in Ruby that should take care of things. With Ruby installed (we can point you to a proper installer if you can't find on), you can install the gem (gem install geoloader) and use the tool with something like this:

$ geoloader geoserver load path/to/geotiff.tif

This is what we use to do most of the heavy lifting for not only working with Neatline, but all of our GIS datasets that get loaded in our infrastructure.


Thanks Wayne,

I have forced the reproject with 4326, but still no image. I'll look into your geoloader.

Thanks again, Jon