Neatline Stamen Maps & Firefox Issues


I’ve been continuously running into issues in using Stamen maps and some cross-browser compatibility with OpenStreetMaps

In any browser, Neatline ignores the options for Stamen maps altogether. Any Stamen map options I have selected in the exhibit settings disappear when the exhibit is viewed. Even if the default base layer is set to a Stamen map, it ignores it and chooses another map in the base layer options. On Chrome (v33.0), IE 11, Safari 7, and Opera (v20.0), the rest of the maps render perfectly.

However in Firefox (v27.0), when I opened up the exhibit using OpenStreetMap, the map refused to display. I then tested Neatline on Firefox v26.0, and OpenStreetMap worked perfectly. When I open the console and interact with the page, it fetches the map data (I can see the GET function grabbing links to the map’s PNGs), but they simply don’t display.

I have deleted and reinstalled all the plugins, but am still having the same problem. All the data I’ve created in Neatline remains untouched—it renders perfectly on all browsers. I also changed the theme in case it was a CSS conflict, but that wasn’t the issue.

Looking at multiple browsers’ consoles, there are a few alerts/errors that pop up on the page’s load (note that these are compiled from a few browsers):
> ReferenceError: Can’t find variable F
> Error: is being assigned a //# sourceMappingURL, but already has one
> Warning: you have included the Google Maps API multiple times on this page. This may cause unexpected errors.
> TypeError: Omeka.moveNavOnResize is not a function

In summary, my main issues are:
- Stamen maps aren’t working in any browser
- The latest version of Firefox doesn’t display OpenStreetMap

The Neatline I’m working on can be found here:

I’m using the most updated version of Omeka (v2.1.4) and Neatline (v2.2.1). Additionally, I have NeatlineFeatures (v2.0.1) and Neatline Waypoints (v2.0.2) installed. Before re-testing and troubleshooting, I emptied each browser’s cache/web data in full.

If there’s any other info I can provide, let me know.

Thank you,

Hey Caleb,

I think you're running into a known issue with the Neatline Features plugin. Can you try deactivating that plugin, and see if the problems resolve? We'll try to push out a fix for Features ASAP.

Let me know what happens. Thanks,
- David

Hi David,

It worked! Looks like all is clear for now. I'll keep an eye out for the Features fix.

Thanks very much!

Just following up on this.

Has any work been done on a Neatline Features fix? I'm working on the same project as Caleb and were hoping to use the Features plugin functionality.