Neatline no longer displaying WMS

I have a couple of rectified maps in Neatline exhibits, pulled in from NYPL and Harvard Mapwarper via their WMS address. As of a couple of days ago, they were displaying just fine, but now WMS rectified maps don't show up. This exhibit should have a map visible by default, and it still shows up in the overlay tab, but the rectified map image doesn't show up.

I've tried disabling Features, tried different rectified maps, and tried in Chrome, Firefox and Safari. The site is running Omeka 2.2.2 and Neatline 2.3.0. The only thing I've changed this week, besides disabling Features, was to add svg as an allowed file extension. Any ideas what to do to get the rectified maps showing again?

Did you recently update Neatline? There's a bug that got introduced that specifically affects WMS from NYPL and MapWarper. There is a branch that has a fix for this on GitHub (you can also download this at

This will be included in the next release of Neatline...


Thanks for the reply, Wayne. I didn't mention in my previous post that I had the png8 branch, but I hadn't updated it since October or so--I'm the post on github having issues with mapwarper previously. For whatever reason, as of last fall I could only get the rectified maps to show up using the tiles export url, rather than the WMS url recommended in Neatline's documentation. Switching from the tiles url to the WMS url just now seems to have fixed it.

That fix has made it in to the master branch now...need to update that ticket. Neatline 2.4.0 will be released early next week...