Neatline: Add record button missing


I am trying to create an exhibit using Neatline 2.3.0 in Omeka 2.2.2. I am able to create a new exhibit using Neatline and import item records from my Omeka database, but when I open the Neatline editor, both the item records and the "create new record" are missing. The map is visible but shows "loading" in the lower right hand corner. Using the Google Chrome developer tools, I see the error:

Uncaught TypeError: Cannot read property 'replace' of undefined

What's going on? Any help would be appreciated!

Anna Michelle

Hi Anna Michelle,

I'm unable to reproduce right now. Maybe some more information would help.

  • What Widgets do you have installed and enabled?
  • What Spatial Layers are enabled?
  • Which is the default spatial layer?
  • Are any WMS layers enabled?
  • Have you changed any other settings from their default values?
  • How many items do you expect to have imported? What do you want to import from them? Dates, locations, or just descriptions and titles?

Hopefully this will help us get to the bottom of this.


Hi Eric,

I've tried it both with and without widgets, with different combinations of spatial layers, and with and without imported items. I've tried deactivating, uninstalling, and deleting the Neatline plugin, and then re-installing it. I've also tried deactivating all other plugins to see if something was interfering, to no avail. Currently, my exhibit has:

  • No widgets installed
  • Stamen Watercolor as the only enabled spatial layer (I've tried with Open Streetmaps, too)
  • No WMS layers
  • All other default settings
  • I've imported 37 items, which show up in the #items column in the Browse Exhibits view. I just need the descriptions and titles in Neatline

Now that I'm taking a closer look at the Google Developer tools, it looks like I'm getting an internal server error and that two records requests are being cancelled. Would this be linked to the Uncaught TypeError or are they two different problems?

Anna Michelle

Hi annamichele,

One more useful bit of info; what version of PHP are you running? If you're not sure, if you click on the "System Information" link in the admin, it should tell you.

Hi Anna Michelle,

Well, that all seems very normal, except for the internal server error. (The two requests that get cancelled, are normal, oddly enough.)

If you haven't yet, could you enable error messages.

Then, open the developer tools and find the line with the internal server error. Can you tell me what the item that it's trying to access (the first column). Then click on that row, and let me know what it says under the Preview and Response tabs that appear in the right-hand pane.

And as Wayne pointed out, the PHP version would be tremendously helpful.


Hi all,

I'm using PHP 5.3.13 (cgi-fcgi) and I don't get any error messages when using error logging or setting Omeka to display error messages.

The path with the internal server error is


The preview shows a white pane with up and down scroll arrows towards the center middle of the pane, as though there were an empty content box.

The response is rather long and I think it's preventing me from properly posting a response, so I'll add it in a separate post.


Ok, I can't post the whole response, but it looks like the HTML of the page. Is there a particular part I should copy out for you?


I'm guessing that the HTML has the error message buried inside it. Could you email it to me at erochest at

Will do!

In case anyone stumbles across this thread in the future, the issue seems to have been with our temporary, shared hosting on iPower. Once we transferred over to the university servers, everything worked fine!

I'm having a similar problem. Nothing appears in the lefthand pane where it should say "Add New Record." I have turned off all plugins except neatline. Interestingly, the issue only exists if I use a static image for my map.

If you open up the JavaScript Console in Chrome (View > Developer > JavaScript Console) or Firefox (Tools > Web Developer > Web Console) and then load the page, does it list any errors?

That might help us know what direction to start looking in.

I was able to resolve the issue by uninstalling and re-installing the Neatline plugin. I think the issue was caused by missing files from copying the Neatline directory to the server. After I copied and unzipped the directory directly on the server, it seems like things are working alright.

Great. Glad you got it figured out.