Neatline 2.2.4: Can't import items via query

I have Neatline installed with Omeka 2.1.4, and I can't import items to Neatline via a query. When I enable error logging, this is the message I get:

Warning: mysqli_stmt::bind_result() [mysqli-stmt.bind-result]: Server returned unknown type 255. Probably your client library is incompatible with the server version you use! in /home/miriampo/public_html/omeka/application/libraries/Zend/Db/Statement/Mysqli.php on line 255

Fatal error: Call to a member function out() on a non-object in /home/miriampo/public_html/omeka/plugins/Neatline/helpers/Coverage.php on line 26

Here's my system info:

Omeka 2.1.4
PHP 5.2.17 (cgi-fcgi)
OS Linux 2.6.18-371.6.1.el5 x86_64
MySQL Server 5.1.73
MySQL Client 5.1.73
PHP Extensions
Regular bcmath, bz2, calendar, cgi-fcgi, ctype, curl, date, dbase, dom, eAccelerator, ew, exif, ffmpeg, filter, ftp, gd, gettext, hash, htscanner, iconv, imap, ionCube Loader, json, libxml, mbstring, mcrypt, mhash, mime_magic, mysql, mysqli, openssl, pcre, PDO, pdo_mysql, pdo_sqlite, pgsql, posix, pspell, Reflection, session, SimpleXML, slog, snmp, soap, sockets, SPL, SQLite, standard, tidy, tokenizer, uploadprogress, wddx, xml, xmlreader, xmlrpc, xmlwriter, xsl, Zend Optimizer, zip, zlib
Zend the ionCube PHP Loader, Zend Optimizer
Coins 2.0.3
CsvImport 2.0.2
ExhibitBuilder 2.1.2
Neatline 2.2.4
SimplePages 2.1.1
Berlin 2.1.3
Omeka Foundation 2.0 (current)
Seasons 2.1.6
Thanks, Roy 2.1.1

I don't know if it's relevant, but I had to turn off background processing because I don't seem to have PHP-CLI on my server.

Thank you!

I don't know if it's relevant, but I had to turn off background processing because I don't seem to have PHP-CLI on my server.

Yup, that's relevant, and unfortunately is the reason why the import is not working for you. We use a background process to import the items that match the search query.

Rats! I guess I had the impression (which I think I got from this question) that you could switch to synchronous processing and still be OK. Is that not right?

Thank you!

Ah, ok! I hadn't realized you could switch to this in Omeka, so I'll look at this a bit more closely. Did you switch to Omeka_Job_Dispatcher_Adapter_Synchronous as David suggested in that thread? The original poster on that thread didn't respond as to whether that worked.

Curious if you might get a similar error using another plugin that does background processing, like the CSV Import plugin. If you haven't used it and have a chance to, try running that plugin to see if it works OK.

Yes, I did switch to Omeka_Job_Dispatcher_Adapter_Synchronous.

Funny you should ask about CSV Import, because that's the reason I initially switched to synchronous processing. It did work after I switched.

Also, what was your search query for the item import?

Well, I tried searching by item number (1-4) and by collection. Both resulted in the same error message.

But wait! Just now I tried searching by Type, and that seems like it worked, because the list of exhibits now shows that I have 3 items in my new exhibit. However, when I try to edit the exhibit, I don't actually see any items in it.

Issue posted to GitHub. If anyone else encounters this, feel free to add a comment there.