MySQL error #1044 when uploading database

I am prepping to move my existing Omeka collection to a new server. I have successfully installed version 1.5.1 on the new server, so no problems there. When I go to upload my old database onto the new server, I receive the following error:

SQL query:

-- Current Database: jmroman
CREATE DATABASE /*!32312 IF NOT EXISTS*/ jmroman /*!40100 DEFAULT CHARACTER SET utf8 COLLATE utf8_unicode_ci */;

MySQL said:

#1044 - Access denied for user 'romanarchivecom'@'' to database 'jmroman'

I tried manually modifying the permissions on the .SQL file, but I still get this error. How can I get the database to upload successfully?

That's a mysql permission error, doesn't have anything to do with your backup file. You didn't gave your user the correct permission to access that database from that address. Check that your mysql user has permission for host % to access the database. When you created the mysql user, you might have only given that account access from only the host localhost and not %.

Thanks. Since I'm using a hosting service (this is a personal installation), I don't have access to the individual user permissions, so I'll have to contact them to see if they can edit these for me. Do I just need to edit the permissions on the destination server, or on the old server that I exported the archive from? Others have suggested that this needs to be done before the file export in order for it to work successfully.

Thanks again!


Just the destination server. It basically just said your account wasn't allow to upload stuffs.

Ok, I got the archive to import successfully! I played around a bit and realized that I hadn't changed the database name within the .sql file-that made all the difference. Thanks for the comments!