MP3 audio file upload problem

G'day everyone,

I've just started tinkering with Omeka (which I was overjoyed to have come across!) but I've run into something of a stumbling block.

When I attempt to "Save Changes" after browsing to an MP3 file that I'd like to upload, my browser window displays a static, blank white page. Then, when I take myself back to the admin area in order to inspect my items, the new item is indeed there, but it isn't associated with the audio file that I tried to upload. Further, when I take a peek inside in the archive>files directory, the MP3 is indeed sitting there, uploaded, and with a sort of alphanumeric affix.

This same phenomenon occurs (that is, being able to add items and upload MP3s, but not associate the two) when I endeavour to use the dropbox.

So, having been able to upload images with no problems thus far, I take it that what I'm describing is an anomaly?

Below is my best effort to spell out the technical details of my set-up (but in replying, bear in mind that I'm not a programmer, nor web designer!).

OS X 10.5.6
Firefox 3.0.8
Safari 3.2.1 (with which I've repeated the above problem)
MAMP 1.7.2
Berlin theme (which I've begun to modify, but I've repeated the above problem using different themes)

Look forward to hearing any thoughts on the above.

Just as an addendum to my first post (if it helps to diagnose what's going on here) I've just experimented with uploading a range of different MP3s, and interestingly, the issue I described above occurs repeatedly with some MP3 files and not at all with others.

From what I can tell, the MP3s that consistently pose a problem (i.e., in leading me to the white screen I described, and in not being coupled with newly added items) are those that only have one channel, or are mono in format. Stereo MP3s, by contrast, seem to pose no difficulty.

To confirm this hunch, I converted a mono MP3 into a stereo MP3, and (eureka!) for some reason it worked, where the mono file didn't.

Hmm, and which version of Omeka are you using? Is it .10 or 1.0 alpha?


Are you able to upload other files, such as images?

It's possible that you're trying to upload files that are too large for your server configuration, so Omeka is timing out when you upload them. You may want to see if the difference between successful file uploads and those that have failed has any kind of correlation to their size.

Thanks for your replies.

Sheila, I'm using the latest Omeka release, 0.10.

And Dave, as I wrote in my original post, uploading images poses no problem. And in regard to the file size hypothesis, I already considered that, having read the other forum threads here on the same topic. However, that's not the cause of the quirk in this case, because I'm able, for example, to successfully upload a 7mb stereo recording, but not a 1.6mb mono recording.

Who knows, maybe it's a gremlin that's specific to my set-up, but it seems curious.

Ticket is up on Trac, can follow its progress here:

Mac, if you're still readign this, I couldn't replicate this bug in 1.0. Do you still get this same error in 1.0? If so, is it possible for you to send one or several of the files you've had trouble with to the dev list, or to me directly?

About a month ago I chatted with a guy on IRC who was experiencing the same problem; the bug relates to uploading a "mono encoded MP3" file. Let's see if we can get a file attached to the ticket for others to test out so we can all be on the same page.