Moving directory failure

We have an Omeka 2 instance going on our server. We placed it in a directory /usr/share/omekatodd and symbolically linked omekatodd from our web tree. We are using the Seasons theme and created a welcome page.

Now we want to change the url name from omekatodd. If I change either the symbolic link name or both the symbolic link and the actual directory name I run into two problems.

First, if I go to the http://ourserver/linkname address I get a 404 error and I notice it is changing the url to be http://ourserver/linkname/omekatodd/welcome. I also notice the theme is not displaying with our modifications. However, if I select the Browse from the navigation bar (or other items) it works fine with our collection.

How do I change the the directory name so the welcome page displays correctly with the standard url?

Thanks in advance.

When we recently changed our URL, we added

RewriteBase /newlink

to our .htaccess file in the Omeka directory. It defaults to /, which might be causing your trouble.

I'd also try editing and re-saving your Navigation, including the home page selection.

The Navigation includes portions of your URL, and when you move it they're still stuck on the old one.

Thanks John and sheepeeh. I tried both things without success but did notice something unusual.

John, when I went to the Appearance/Navigation I see references to the old location that I want to change. However, it does not allow me to change them. Only the label. What is curious is that when I DO change the directory name the navigation bar works. Only the welcome page doesn't.

sheepeeh, we are not changing our base url, only the part after the base.

It's for changing the directory, not the base url, though that's a bit counter-intuituive. We went from http://home/ to http://home/exhibits/exhibitname

There are some built in Nav links which cannot be manually changed, as far as I can tell. To get around this, uncheck the default link and create a new link with the desired label and link.