Moved to new server, 500 Server Error

I recently decided to move to a new hosting service (inmotion) and I've had the strangest problem with my Omeka site. I backed up all of the files (and database tables), restored it to the new server and it only generates 500 Server Errors, BUT nothing is left in any log files.

Tech support wasn't able to see anything either.

I've gone into every config file I can find to turn on debugging and logging.

I tried simulating a request from the console and I'm seeing all of the database operations (98 of them) I'd expect, but no output (other than a print_r of the application object I stuck into index.php ... and I'm not seeing any output when run through the web server.

I suppose the next step is to do a separate fresh install of Omeka in another folder and see if this is systemic, but I thought I'd ask if anyone had any ideas on either why copying an installation would have issues OR how to increase the amount of logging?

This is really weird...


- dave

I'm grasping at straws here, but a couple things I'd check

.htaccess -- make sure it's there and has the right debugging settings

file permissions -- make sure it's all readable by the server, and the files folders are also writable

try doing a brand new clean install, without copying the database and files. That might reveal something that Omeka can detect in the install process

Thanks Patrick. Already did items 1 and 2 to the best of my knowledge. Item 3 is on the agenda for later today.

Also, it might be worth checking what version of Apache inmotion has you on. We've seen oddities elsewhere with version 2.4, and going back to 2.2 resolved them. Not sure of the details on the specific problem, though.

My hosts upgraded the servers last weekend and I now have the same issue (ver 2.3).

I commented the rewrite rules in htaccess and the error changed from 500 to 404 - so it seems that the problem lies somewhere here:

RewriteRule ^install/.*$ install/install.php [L]
RewriteRule ^admin/.*$ admin/index.php [L]
RewriteRule .*$ index.php

It seems harmless enough but clearly there is something wrong.

If it's an .htaccess directive causing the problem, that should definitely be logged in Apache's error log, so you or your host should be able to look there and get more detail on what's happening.

That is the odd thing John. There is nothing in the logs.

I am seriously scratching my head here. Htaccess has always been a bit of a dark arts area to me.

It's pretty unlikely those RewriteRule lines are the actual problem. They don't really do anything interesting. Have you tried going directly to index.php? Do you still get a 500 error then?

The logging issue is a strange one. Apache is usually very good about logging errors.

I can go to the main page when I comment out the rewrites.

But I can't go to collections/index.php which is where my client wants to lead her readers.

After much head scratching and calling on serious geeks, this little problem could not be solved.

Client decision ...

We have closed down Omeka (too much bother).

A Sad Day.