mod_write and paths problem on install

Hello, We have been trying to install Omeka 1.5 for the past two days.

We are getting the error message "mod_rewrite not enabled" and have exhausted all of the advice on the forum, as well as the knowledge of myself and my sysadmin.

Specifically, we know that mod_rewrite is working on the server. It is listed as an apache module in our phpinfo files. In addition, wordpress, which is installed on the same server, uses mod_rewrite without any trouble. Finally, a testing script that we put in omeka's root folder--which we renamed 'exhibits' is also working correctly:

In our apache conf file, we turn have the following directory entries

<Directory "/ourrootfolder">
Order Deny,Allow
Allow from all
Options Indexes FollowSymLinks
AllowOverride FileInfo

<Directory "/ourrootfolder/exhibits">
Order Deny,Allow
Allow from all
Options Indexes FollowSymLinks
AllowOverride All

In the .htaccess, we have tried leaving the RewriteBase commented out and have also tried several different values matching the absolute paths to omeka folder. I have also tried several different values in install/.htaccess.

As far as I can tell, the source of the problem seems to be something with the paths

If you visit the location where we are trying to install omeka, you can see var_dump of several of the variables set in paths.php

WEB_ROOT = string(53) ""
WEB_DIR = string(53) ""
ADMIN_BASE_URL = string(23) "/exhibits/install/admin"
PUBLIC_BASE_URL = string(17) "/exhibits/install"
CURRENT_BASE_URL = string(17) "/exhibits/install"

These do not look right to me. Any advice you have provide is appreciated.`

It does look like mod_rewrite is enabled on your server.

This means the problem's happening when the installer tries to check that URL. Probably, your server's set up in such a way that it can't access its own URL, which normally indicates some DNS or hostname issues on the server side.

Can I disable the check to see if the install will proceed without the check?

In what file is the check taking place? I had looked for it, but couldn't find the file in the install folder.

OK, we managed to fix this problem.

It was in our etc/hosts file, for some reason the host entries had gotten messed up. Once we fixed that problem, everything works smoothly.

Thanks for your help, since looking at DNS put us on the right track.

Hi - what order are those entries supposed to be in?

I'm having the same problem with mod_rewrite, and it's frustrating. I'm ready to go back to the digital library I was using before, which was nowhere near the hassle to install that Omeka has been, and worked perfectly.