mod_rewrite + URL's not found


I've been trying to install Omeka, but without any success. I've be trying one time on a VM running Ubuntu 14.04, with apache2, and a second time on a Debian Wheezy, with apache2 too.

I tried with the latest ZIP on the site, and also after cloning the github repository.

I get the same problems. Which are :

1. The very well known problem of the mod_rewrite which is enabled, but not for Omeka. When running a2enmod rewrite, it's says : already activated.

I went into the .htaccess, uncommented the RewriteBase, gave the path to the Omeka directory, restarted apache. Doesn't work. The install URL keeps saying mod_rewrite not enable.

Reading some there ( ), I try to type [my-ip]/Omeka/install/install.php which worked.

But then, the button "Admin Dashboard" gets also a 404. So I type in the URL bar : [my-ip]/Omeka/admin/index.php, which worked.

But, of course it's the same with a lot of link and URL.

I hope there's a way to fix this ! :)

Thank in advance for any help.


If admin/ isn't working, and you have to go to admin/index.php, then mod_rewrite's not working.

Just having the module active isn't the end of the story. You already said you tried RewriteBase, which is the other usual culprit (the right setting would be RewriteBase /Omeka/ from the URL you posted).

The other somewhat common cause is the AllowOverride setting from your Apache server or virtual host config. Some servers and distributions set AllowOverride none which basically means the whole .htaccess file is ignored, including Omeka's rewrite rules. AllowOverride all is the setting you want.

Hi John,

Thank you very much for your answer.

The error was in the .htaccess : the setting for RewriteBase wasn't the right one, your solution is.

Everything seems ok now.

Thanks again !

Dear 1g0r,
I had the same problem. Ubuntu 14.04 Apache2 and Omeka don't work well. I guess Ubuntu 14.04 don't tolerate apache2 very well. For now, using Ubuntu 12.04 seems to be a better idea. It made the mod_rewrite easier to configurate.

Hello MPZ,

I don't think that "Ubuntu 14.04 don't tolerate apache2 very well". But it seems that Apache2.4 is slightly different to configure as Apache2.2...

Yes, it's definitely not any problem with Ubuntu 14.04 and Apache per se, instead it's just that it's a newer version of Apache.

The specific mod_rewrite issue with Omeka and Apache 2.4 is actually fixed as of 2.4.9. A quick glance shows that 14.04's version is too old to have that fix, but 14.10 should be new enough.

Thank you both for this information!

Yes, I was having fits with the mod_rewrite issue, so I installed Apache 2.4.9 manually (the latest version available from Ubuntu for 14.04 LTS is 2.4.7) from this source:

Specifically this section:

Running Apache 2.4.9 won’t hurt you though:

$ add-apt-repository ppa:ondrej/apache2
$ apt-get update
$ apt-get install apache2
$ apache2 -v
Server version: Apache/2.4.9 (Ubuntu)
Server built: Apr 1 2014 08:39:50