mod_rewrite issues under OpenSuSE 11.2

I am having real problems getting Omeka to install under OpenSuSE 11.2. I ahve copied all files (including .htaccess), verified via phpinfo() that mod_rewrite is runing, and set the AllowOverides All directive in my Apache2 config file. I did also fix the PHP 5.3 compression error as well, and did a chmod 777 to eliminate all issues with permissions. Of course I checked and my database is working and the ini is set with the correct passwords. I tried several alternatives on the base url in the .htaccess files, none work. Omeka is working on a test server under another OS, but I can't get production running yet.

Is there a clean set of documents with the proper configuration of the Apache2 config file (known working, and known working .htaccess directives (say installed under the document root in an omeka directory)?

Is there any interactive or other help available? I can provide copies of my files, etc. and I am continuing to look at mod_re_write, but it does appear to be active.

Any help will be appreciated as this is a critical blocking issue in the install of a site for a faculty member's research project. I really would welcome know working sample configurations and config files as they could be used to reference against target produciont configurations.

I know this is not supposed to be so hard. As usual, mod_rewrite errors get very difficult to find and fix. If I need to use another PHP version as well please let me know. I am currently at a clean 11.2 64bit install of OpenSuSE 11.2 using all packages from the current default repos for the OpenSuSE project (as vanilla as I can get).

Thanks in advance.

Cecil Thornhill
Sr. IT Department

Have you tried adding a RewriteBase directory to the .htaccess files located in your root directory, your install directory, and your archive directory.

Tell if this helps:

Thanks wanderingwill, I was actually just about to post that I "self-rescued" just now. It was not actually the RewriteBase (as I also thought), but a global issue. In this distro (and some others) there is now a default-server.conf file in addition to the httpd.conf file. You can turn on mod_rewrite all day long, but if you don't set it in the default-server.conf file it won't work.

I am old enough to long for the days of the simple conf file you edit by hand. At least you know who to blame...:-)

Anyway, I got that fixed, added phpexif, and commented out the compression code for the php5.3 bug and all is now very well.

About 3 days late, but well. I really appreciate the help. I have to say that there is a heck of a lot of pain on the web over mod_rewrite when you start searching for it, and lots of it is just the silly conf stuff - getting it turned on to play with. I think there is a real need to standardize and document all the darn changes to Apache2 installs and configs. Not an Omeka issue, but I bet it would help. The fix was 5 min. but finding it was 3 days.

Anyway, now I look forward to what I am really supposed to do, which is set up an Omeka site for a new collection of documents from the 19th century.

thanks again to all.


Hi, cthornhill,
can you show us what you entered in to the
As I have the same issue with it in Suse 11.2


Sorry not understanding what you mean,
Can you give a for instance?