mod_rewrite issue

Ok... so after a couple of hours of trying to get the user and database set up on mysql (i'll send a message with what worked for me - the instructions on the website didn't work), i am now having trouble with Omeka saying that 'mod_rewrite' is not enabled.

I followed all of the instructions I could find on google, to a TEE, on ensuring that mod_rewrite is indeed activated. But i'm still getting the error message. WHY?

Thank you.

(sorry if this sounds frustrating - it took me over 8 hours to set everything up to use Omeka - it was recommended by a colleague, but i'm starting to regret trying it.)

If you're sure you've got mod_rewrite enabled, you likely have a DNS problem: your server doesn't know how to "find" itself from its domain name.

If you have the IP address for your server, that's often the easiest way to get around this: just for the install process, go to your site using the IP instead of the domain.

Otherwise, it's usually a matter of adding a proper line to your server's /etc/hosts file, something like:

(The part should stay the same, it's the "localhost" IP loopback address, and "" should obviously be replaced with your actual domain name)

Thanks for replying!

Unfortunately, that didn't work. :( I tried changing the DNS entry, and also tried the IP address. But no luck.

Ok.. so just so i'm clear: to enable mod_rewrite, I need to have the following in my httpd.conf:

-have the correct LoadModule statement
-set AllowOverride All on the DocumentRoot directory (my omeka directory is in here)

I did both of these steps (the first was already done, the second I did). But it's not working, and your above suggestion did not work (and I did restart apache, in case that needed to happen too). I'm at a loss as to how to fix this.


Do you have Apache settings that are fooling with the mapping between filesystem paths and URLs?

If you're using Alias directives, or things like ~username in the URL, you often need to set the correct RewriteBase in Omeka's .htaccess files.

The RewriteBase should be all the parts of the URL after the domain name, but before the Omeka path. So, if Omeka is in the domain root, it would be RewriteBase /, if it's at, it would be RewriteBase /some-dir/, and so on.

I'm sorry you're having so much trouble getting Omeka installed. You've covered most of the usual bases, enabling the module, AllowOverride, and checking DNS settings (you can confirm you've gotten those right by having your machine ping itself). After RewriteBase, that's all the obvious culprits really.

Thanks! It's working now.

Hello John,

I ahve the mode_rewrite issue.

I correct LoadModule statement and set AllowOverride Allbut still not working.

My omeka is renamed bibliographieand I'm using a localhost (to access the omeka installation Igot thgough so what would be the RewriteBase / for me?

RewriteBase /bibliogpahie/ ?

Please advice. I'm realy stuck with the installation and spent over a day trying to fox this)

I have the same problems. Fortunately the boys from nextpointhost resolve my issue.

The problems with mod_rewrite come due incorrect DNS records.

The DNS records must to point to the server where you try to do the installation.

For example if you try to install Omeka on domain and ip address of the server is

You need correct A DNS record for to ip address

Otherwise you need correct records on both hosts files - your local hosts file and host file on the server like this:


In brief if DNS records are not correct. the hosts pointing must to be bilateral