mod-rewrite issue for installation on virtual server

I am attempting to install an instance of Omeka on a sandbox virtual server on my home computer (Ubuntu/VirtualBox). Everything went smoothly up until the point of install where I am getting the dreaded "mod_rewrite is not enabled" error. I checked every instance of AllowOverride I could find to change it to All instead of None, and according to my Apache, modrewrite is enabled. I have RewriteEngine On and the RewriteBase set to the folder of the installation. I also have a running installation of WordPress up so the server itself seems to be functioning correctly. Any ideas on what I should try next? Or is this type of configuration an issue for Omeka?

Wordpress doesn't require mod_rewrite to function, only its "pretty permalinks" do.

Note, if you have to make a RewriteBase setting, you probably also have to have one in the install directory's .htaccess (install/.htaccess). Of course, you'd have to add the /install/ part of the path to that sub-directory's RewriteBase.

The other general possibility is that your virtualized server can't access itself. Try going to the install by IP address, not a domain-like alias, if that's how you're currently trying it.


We had the same trouble while trying to install Omeka on Apache behind a proxy on a Debian/Xen virtual machine. The trick found by the sysadmin was to add to /etc/hosts and comment it once the install was done.

I don't know if it's your case but that's easy to test.