missing file during install?

I'm trying to install version .10 from the zip I just downloaded. No matter what page I try to go to it says "Lost connection to MySQL server at 'reading initial communication packet', system error"

The error_log file reports that the file "/var/.../install/components.css" is missing, which is correct it is not in the install directory. Where can I get this file or should the program be looking in a different location and if so how can I get it to do so?

Hi Kelly,

It sounds like this is a problem with your MySQL connection, and not relating to the missing css file. Have you installed a previous version of Omeka on your server with the same database information? Double check and let us know.

Good luck,
Dave Lester

Hi Dave,

It is a yes/no answer about the MySQL connection.

Just a quick bit about our set up, the Apache/PHP box with Omeka installed is in one subnet, the MySQL box is in another. There is a firewall between them with a rule to allow MySQL access via a particular port.

We have other php programs running on the same server that can connect to databases on the MySQL server with no problems.

Have added the port to the db.ini file of Omeka but still no go. Has anyone tried Omeka in this type of environment? Is there any reason it would not work with a firewall between the php and database?


It seems to be an issue with a couple of variables in the my.cnf file.

Per these forum posts:

http://forums.mysql.com/read.php?52,151255,151255#msg-151255 (look through all messages, they basically say change the bind address)

http://forums.mysql.com/read.php?52,234903,235833#msg-235833 (this one talks about changing the max allowed packets)

Try changing the "bind-address" to either be the internal IP (192.168.x.x) if the servers are on an internal network, or the WAN IP (the one accessible to the world).

Also try changing the max_allowed_packet to 16M or 32M.

Please post back if that works, or if you get it to work in any other way for the benefit of future users. :)