mapping a CSV column data to multiple elements?


I have tried to map a CSV column to a a couple of Dublin Core elements but it doesn´t work. I´m not sure if it´s only me or if it's a bug because the CSV Import plugin allows to map a column to a various elements but in fact it only seems to work when is map to a single element.

For example, with the test.csv file that comes with the plugin, if you tried to map the column creator to DC Creator but also to DC Subject, it doesn´t import any data to any of the elements.

Any ideas?


Could I ask what version of Omeka and the CsvImport plugin you are using? When I try with Omeka 1.5 CsvImport 1.3.3 I can't reproduce what you are getting.

Hi Patrick,

I´m using Omeka 1.5.1 and CSV Import 1.3.3


I have also tried with Omeka 1.5 and CSV Import 1.3.3 and only get the second element mapped. In the above example, I get the data in the column creator only in the element subject but not in the element creator that was selected first

Hi Patrick,

Sorry to insist again. So, can you confirm that when you map a column with more than one element, the content of that column goes throught in all the elements?

I can´t make it work and it is quite important for our project as we want to map all the different names in two elements: in Creators or Contributors and at the same time in Persons and Organizations (two new elements that we have created with a new element set)

We´re hosting our installantion in Dreamhost which currently uses PHP version 5.2.17. Could that be the problem? It is needed version 5.3 for the CSV plugin to work correctly?

Can other people using Dreamhost reproduce this problem?

Everything else is working correctly with the plugin, even the ability to map an object with different files in different columns(after doing this little hack: )

Thanks for your help. Regards,


Sorry about the gap in communication. Yes, it's working as expected for me.

As far as I know, it should work with PHP 5.2.17. I'll see if I can find someone here with an installation on Dreamhost to try it out, though.

It's a long shot, but only other thing I can think of is something odd in the javascript when you click the button to add another field to map to. What browser are you using?

Hi again Patrick,

I have tried with different browsers: Firefox 12.0, Chrome 19, IE 9. In all of them the Java Script was enabled.

On the other hand, I think you are in the right track. In version 1.3.3 of the plugin, in order to map a column with a second or third element, you must click in a little green icon with a plus sign. This icon only stay with the last element added which is the only element that gets imported at the end.
However, I tried with version 1.3 of the plugin which doesn´t use these icons and works fine for me, importing all the elements.

But..too happy too soon. I don´t think it was a good idea to use version 1.3 of the plugin with Omeka 1.5.1. When I tried to deactivate and uninstall the plugin, the following error page appears:

Zend_Session::start() -
../application/libraries/Zend/Loader.php(Line:146): Error #2 include_once() [function.include]: Failed opening 'CsvImport/File.php' for inclusion (include_path='../application/libraries:../application/models:.:/usr/local/lib/php:/usr/local/php5/lib/pear') Array

The error page stay there and I cannot do anything with Omeka after that. It happens to me in two installations of Omeka. In one of them I was able to get rid of that error page after deleting (using FTP) all the plugins.

Do you think changing the form of the CSVImport 1.3.3 for the form in version 1.3 will do trick?

Thanks a lot for your help,


The problems wasn´t so big after all. To get rid of the error page appearing after trying to "Deactivate" the plugin only was needed to load Omeka in a different web browser. So I´ll use version 1.3 until my purpose until something better comes up.

Thanks again