Login redirects on itself


I was running Omeka 2.3 site on the MAMP server and then moved it to another server as a subdirectory within a Wordpress site with Bluehost, through which it upgraded to Omeka 2.4.

The user-end is running and working well. However, when trying to login to the admin with the only user account I have, the login page redirects on itself.

I already tried specifying the Rewrite Base to the Omeka subdirectory and that did not change anything.

I am also having trouble following previous forum posts on this topic which mostly are working with previous Omeka versions from 3-8 years ago.

Curiously, the account information is no longer working for with the local MAMP server either.

Where should I start?

Not exactly sure what it might be off the top of my head. I'd first make sure that the url it's getting to is something like Omeka/admin/users/login. I'd try clicking the 'lost password' link and seeing if it can go through the password recovery system to get back to the admin side.

Is what's on your local server the same copy of the database that you used to move the site? If so, I'd suspect a corruption of the database itself.

I already tried changing the password and inserting a new password and that did not work.

What is on my local server is the same copy of the database that I used to move to the site. The only difference is that the one on the site was updated to 2.4 and is on Wordpress. If the database was corrupted, what can I do about it?

Something else I noticed was that in the users database in phpMyAdmin the password for the superuser account did not match the user's password I have been using and was unusually long. I am not sure if that is what it is supposed to look like.

I also noticed that the id's for the sessions logged in were quite long and I read in one of the other forums that this could pose a problem. Unfortunately I cannot follow what was done in this case. http://omeka.org/forums/topic/admin-login-screen-seems-to-redirect-on-itself

I'm not sure how much what's in the old thread will be relevant, since it's from a much older version of Omeka, but it might be something related. If it is a sessions problem, sometimes trying with a different browser sometimes works.

The difference in stored password and what you entered is expected -- we don't want to store passwords exactly as they are entered for security reasons.

Hi Patrick,

I have opened the admin page in different browsers and on different computers which did not work.

I have re-installed a new version of Omeka on to the server site without transferring it from the previous server and the login keeps redirecting itself.

I spoke to someone from my server host who said that the specific server the site is working with is made to host Wordpress and may not be able to host other scripts, including Omeka.

I am wondering if there are ways to test whether this is the problem and to solve it or if I have to install Omeka on a different server.

Is there anything else I can do to redirect the login to the admin dashboard?

Thank you

If things are configured specifically for WordPress, then that could explain a lot -- we often see similar problems when people try to install WP and Omeka in parallel directories.

I'd double check that the .htaccess file on the server matches the one in the download of Omeka, and maybe whether Bluehost can give guidance about rewrite rules there might undo whatever WP-specific settings they have.

I changed the server to be shared hosting as opposed to Wordpress specific and now the site works.

Thank you for your help!