"Is exactly" Advanced search not working

The Problem:
The "is exactly" option for advanced search doesn't appear to be working correctly. When used with a specified Dublin Core field, it returns 0 result sets even when the installation has items that have the exact text searched for stored in that field.

When used without a specified Dublin Core field, it finds items that have the exact text in their metadata, but it also finds items that do not have the text.

The obligatory:
Omeka: 1.4
PHP: 5.2.17 (cgi-fcgi)
OS: Linux 2.6.32-42.1.BHsmp x86_64
MySQL Server: 5.1.56
MySQL Client: 5.1.56

PHP Extensions:
Regular: bcmath, bz2, calendar, cgi-fcgi, ctype, curl, date, dba, dbase, dom, exif, filter, ftp, gd, gettext, gmp, hash, iconv, imap, json, ldap, libxml, mbstring, mcrypt, mhash, mime_magic, mysql, mysqli, ncurses, odbc, openssl, pcntl, pcre, PDO, pdo_mysql, PDO_ODBC, pdo_pgsql, pdo_sqlite, pgsql, posix, pspell, readline, Reflection, session, shmop, SimpleXML, soap, sockets, SPL, SQLite, standard, sysvmsg, sysvsem, sysvshm, tidy, tokenizer, wddx, xml, xmlreader, xmlrpc, xmlwriter, xsl, Zend Optimizer, zip, zlib
Zend: Zend Optimizer

Could you share a link to your Omeka site, or an example of a search you've tried that hasn't worked, and an example item that should be returned?

All the advanced search options, including "is exactly", don't work at all if you don't select a specific metadata field. The search code will behave as if that advanced search line doesn't exist if no field has been selected.