Ipaper Plug-in not uploading images correctly


We're using Omeka .10 with the iPaper plugin on a CentOS 5 box with Apache 2.2.3 and PHP 5.2.6. The database is MySQL 5.0.41 on a Windows NT box. The iPaper has been enabled and configured.

When we add a pdf document to an item we are getting the message "Error Document failed to convert". The actual pdf document is loaded on the Omeka server. Also when I check My Documents in our Scribd account there is a document listed with the status "conversion failed".

We are able to directly upload the same document(s) onto the Scribd server with no problems.

Any pointers or help with this would be greatly appreciated.


I've encountered this error before and am unsure why it occurs. I assumed it was a third-party problem and beyond my capacity to correct. After some looking I found that the error is not uncommon:


My initial thought is that your files are somehow inaccessible to the Scribd servers and therefore unable to be converted. I don't know how much I can help, but I can suggest some things: first, make sure that you entered your website's URL in your Scribd API user account; then log out of Omeka and try to access a PDF via its absolute path (http://example.com/archive/files/file.pdf). If you can't access the file in this way, the error is completely independent of this plugin's implementation. Try this out and get back to me.

On a related note, it has come to my attention that QuickSwitch (the embedding technology used in our iPaper plugin) has been deprecated by Scribd:


Maybe this has something to do with the error.


Hi Jim,

I believe I have entered the correct but just to verify:

For the Omeka's Scribd Publisher ID the Scribd API Publisher ID was entered but should it be the API key?

On the Scribd side for the website URL only the host name was entered. Do I have to enter the exact path to the Omeka site and if so how deep, i.e. /admin/..., does the path have to go? We have multiple Omeka sites installed on the same server (same hostname) so I'm hoping the hostname alone is enough.

Thanks for help


You should enter your publisher ID, the one that starts with "pub-".

The host name should be sufficient.

Have you tried logging out and accessing the files directory via their absolute URL, i.e. http://example.com/archive/files/[filename].pdf (not http://example.com/admin/files/download/[fileId]/fullsize)?

I really think this is an error on Scribd's side, but I'll take a closer look at it.

Hi Jim,

The publisher ID is correct. The page also loads correctly when going to http://content.mnhs.org/maps/archive/files/pressrelease[1]_b7fc67bc6f.pdf.

I'll do some more checking on the Scribd boards and testing here.



This problem has been resolved. Turned out to be a problem with the DNS entry for the hostname. We have an internal DNS that worked for us, the world uses an external DNS which is where the problem was. Basically Scribd could not find the Omeka server.

Thanks for the help.