Invalid MediaWiki API URL issue

I have successfully performed an Omeka1.5.3 install at domain, placed the most current Scripto plugin in the right place, created a database for the MediaWiki1.21.1 install, and, according to the final screen of the MediaWiki installation steps, I am successfully installing MediaWiki at

My problem is when I go into the Scripto configuration screen and put the url to the MediaWiki API into the corresponding box, I get the dreaded "invalid MediaWiki API URL" message (the path I use is I successfully installed Omeka/Scripto/MediaWiki combo on my local MAMP server three times in preparation to put it all online. But after four tries, reading the MediaWiki documentation,and reading the forum (such as this: and this:, I find that none of these solutions seem to apply. What could I be missing?

I have placed the "http://" before the url. I've looked for the "$wgEnableAPI = false;" line in my LocalSettings.php file, but it is not there. I did not find a
"$wgGroupPermissions['*']['read'] = false;" line either.

I tried adding a "$wgEnableAPI = true;" line to the LocalSettings.php file, but to no effect.

I'm stumped. I had flawless installs to my MAMP localhost, and my hosting service, DreamHost seems to have everything in place on their end. What am I missing? I am hoping it is something simple, but I've tried all of the troubleshooting that looks "simple" to me!

Thanks ahead of time!

--Cedrick M.

Installing MediaWiki under the Omeka directory causes this kind of problem. I recommend that you install another MediaWiki instance somewhere else, outside of Omeka, and point the Scripto plugin to that API URL.

That was it! Thank you for your help with this.

--Cedrick M.