Invalid Directory for ImageMagick

I am using Omeka through MAMP on a Mac OS Snow Lion 10.6.8 and I can't seem to get the ImageMagick directory properly configured. On my settings page it appears as Applications/MAMP/htdocs/omeka-2.0.3/ImageMagick and that is indeed where it is. I have seen lots of forums that discuss problems with ImageMagick and MAMP, but they are way over my head: I am not a developer, just an art historian trying to use Omeka in my research and scholarship at Duke. Is is possible to put in relatively plain speak how I should go about configuring my ImageMagick installation properly? Many thanks to anyone who can help!

Oops I meant Snow Leopard

I hope you found a solution before now, but just in case, the first post on this conversation string worked for me: . I tried many solutions before this one, but Jtalbert's fix was the right one for me.

You may need to make your system show hidden files by opening your Terminal (which should be in "Applications/Utilities/") and typing in the following two commands:

defaults write AppleShowAllFiles True

and then

Killall Finder

Type them *exactly* like that and then you can see the hidden files on your system. Navigate from the Macintosh HD to "usr/local/bin", and follow Jtalbert's instructions for dragging and dropping the ImageMagick files into the bin directory. Then the path you need to put into your Omeka install should be "usr/local/bin" and the test button should say "Works!"

To hide your all those messy "hidden" files again, just type in the last two Terminal commands again, but switch the last part of the first command from "True" to "False" then "Killall Finder".

I hope this helps.

--Cedrick M.