Instructions for shared server installation

I am having a sequence of problems installing on a shared server and I'm wondering if there is documentation to help with this process. I have searched the forums and haven't found anything specific - just answers to problems as they crop up. I'm wondering, for example, if the installer will create a database automatically, or if it has to be done by hand (as the Fedora/Ubuntu installation suggests) and what files need to be changed as the manual configurations are done. Thanks.

These kinds of details are likely to be different across different shared hosting providers.

Our instructions aim to be applicable for most people, regardless of their more specific situation.

Unless your host specifically indicates otherwise, there probably won't be much or any automatic setup happening. Omeka's installer won't ever create a database, it requires you to specify an already-existing one in db.ini.

The specific process for creating a database or the credentials for an already-existing one you may have would be something your host should have documentation for.

A limited number of hosts offer some form of automated setup for Omeka. If that's the case with your host, they'd really be the source for information about that.

Got it. I was wondering precisely these types of settings (db.ini for db customization). These pointers are very useful. I'll try to install it and keep asking questions. Thanks for the help.

I have followed the steps here (
I configured db.ini/created a database, made sure to specify a working TMP directory in config.ini and confirmed with the server that mod_rewrite is turned on.
Now I navigate to the site and I get a strange message: "Failed to execute command: which convert." I can't find any reference to this in the forums. Any ideas? (site is: Thanks!

One addition: I looked around the forums and found an older discussion mentioning the directory to "convert". I asked my provider and its "/usr/local/bin/convert". now I can't find where this should be added. I tried the Test.php file to no avail.

I tested that convert works on the server and set the appropriate env variables, but I still get this error "Failed to execute command: which convert" ( Any ideas?

And yet more - PHP log says it can't run "proc_open()". I search for this on the forums and there is nothing. Provider says it can do nothing since it is a shared server. Suggestions?

You might need to check with your host and see if they can enable exec or proc_open for PHP or change some related setting.

This particular command is just Omeka trying to "guess" where ImageMagick is located on your server. The fact that a failure here stops the install is our fault, and we can fix that problem.

However, if you don't have permission to run external scripts at all, Omeka won't be able to generate derivative images.

I heard back and "proc_open()" cannot be enable, but they say " shell_exec" is. Is this a fix of some sort?

Omeka 2.0 uses proc_open to call ImageMagick to create derivative images like thumbnails for items.

Many/most themes depend on those thumbnails for display on browse and details pages for items. You can use Omeka without the derivatives working, but it's a very "core" feature.

I am having the same problem. My server had imagemagick installed. If you can provide some more guidance for resolving this, I'd appreciate it.

No solution. Either have proc_open or it doesn't work. I gave up and will either use another digital library or find another server ;)


after a long series of issues and asking my web host for permissions, I managed to install Omeka on a shared server with the web provider HostPapa.

Up to a few weeks ago, I was unable to upload files. I would get an error message returned. I asked my webhost to check server's PHP/Apache logs and make sure they're writable, to which they responded: "omeka requires 512mb and because we are shared hosting environment the maximum that we provide is 128mb. So in this case I would suggest a dedicated server or vps."

Yet, quite unexplainably, I was recently able to upload some files, without changing anything. Is this luck? Will I eventually reach a point when it database returns an error message and lose all the work I've done up to now? Do you recommend switching to another server right now before that happens? Have other people been able to run Omeka on shared servers?

Thank you.

I'm not sure where they're getting "omeka needs 512 MB" from, and if they're talking about total server memory, PHP's memory limit, MySQL memory, or something else entirely.

People have definitely run Omeka on shared-server hosts, but even with shared servers, all hosts are not created equal in terms of features they restrict or allow, and the general quality of their support.