installing on OHV

I have this error message when install on an OVH host... some help ? :

Fatal error: Uncaught exception 'Zend_Config_Exception' with message 'syntax error, unexpected '=' in /home/infolit/www/omeka/application/config/config.ini on line 259 ' in /home/infolit/www/omeka/application/libraries/Zend/Config/Ini.php:182 Stack trace: #0 /home/infolit/www/omeka/application/libraries/Zend/Config/Ini.php(202): Zend_Config_Ini->_parseIniFile('/home/infolit/w...') #1 /home/infolit/www/omeka/application/libraries/Zend/Config/Ini.php(126): Zend_Config_Ini->_loadIniFile('/home/infolit/w...') #2 /home/infolit/www/omeka/application/libraries/Omeka/Application/Resource/Config.php(27): Zend_Config_Ini->__construct('/home/infolit/w...', 'site') #3 /home/infolit/www/omeka/application/libraries/Zend/Application/Bootstrap/BootstrapAbstract.php(695): Omeka_Application_Resource_Config->init() #4 /home/infolit/www/omeka/application/libraries/Zend/Application/Bootstrap/BootstrapAbstract.php(638): Zend_Application_Bootstrap_BootstrapAbstract->_executeResource('config') #5 /home/infolit/www/omeka/application/libraries/Zen in /home/infolit/www/omeka/application/libraries/Zend/Config/Ini.php on line 182

Huh. I looks like something weird in the configuration file.

From your Omeka installation, could you open up application/config/config.ini and post up (or link to) the contents of the file? Looks like there's something odd on line 259

Thank you !
I imported again all installation files, without modification. The installation went smoothly and Omeka works but I still not have solved the problem of ImageMagick Directory Path.
Is this : a solution for OVH users ?

I've tested :
- the Daniel-KM's solution
- the modification of the fileDerivatives.strategy line (to "Omeka_File_Derivative_Strategy_Imagick") in application/config/config.ini
... these solutions makes both Omeka unreachable.

In the present state of my installation, I can create items but can not attach any document (image, text, pdf, doc) at these items ('add new file') ... omeka return : "Omeka has encountered an error"

Thanks for help,


More details about the error will help -- retrieving error messages should show more.

It's also possible that imagemagick itself or the PHP library Imagick aren't installed. When you go to Settings, at the bottom of the page there's a place to test imagemagick path. What are the results of that test?

Thank you Patrick,

Left blank, the message is : "The ImageMagick directory path does not work." With "/usr/bin/", I receive the same message but, with the path set as /usr/bin/" I don't retrieve error messages ...

I can then upload contents (image, text, pdf, doc) and they appears with a link in the public page ... but without pre-view image :

When I use the omeka test server, I see this pre-view :

I think we approach the solution ...



I'd ask you server admin or hosting company what the path to imagemagick should be.

If you have command line server access, you could also try which convert on the command line, which should tell you the path.


My old gist may not work anymore, but I have a site on Ovh and I use this special plugin :


Daniel Berthereau
Infodoc & Knowledge management

merci Daniel (and tanks Patrick ;-) )

J'ai téléchargé et installé le plugin "OmekaOnOvh" mais lorsque je modifie le application/config/config.ini le système affiche une erreur : "Omeka has encountered an error" (qui ne s'affiche pas malgré la ligne la modification .Htaccess (retrait de # pour la ligne "SetEnv APPLICATION_ENV development")...

Bonne soirée,



Le plugin automatise le processus indiqué par Patrick. Attention, dans config.ini, il faut bien mettre chaque paramètre sur une ligne différente.


Daniel Berthereau
Infodoc & Knowledge management

Indeed, the two lines were on the same line.
Everything seems to work fine now.
Thank you Patrick/merci Daniel !