Installing error

I have no programming experience, and have tried following the instructions to install Omeka on my server ( several times, always to no avail.
When I go to the omeka directory on my server, I get the message "Omeka has encountered an error." with no additional information. When I go to the omeka/install directory, I get this error:

Fatal error: Uncaught exception 'Zend_Db_Adapter_Mysqli_Exception' with message
'Access denied for user 'museumist'@'' (using password: YES)' in /services2/webpages/util/m/u/ Stack trace:
#0 /services2/webpages/util/m/u/ Zend_Db_Adapter_Mysqli->_connect()
#1 /services2/webpages/util/m/u/ Zend_Db_Adapter_Abstract->query('SHOW TABLES LIK...', Array)
#2 [internal function]: Zend_Db_Adapter_Abstract->fetchAll('SHOW TABLES LIK...')
#3 /services2/webpages/util/m/u/ call_user_func_array(Array, Array)
#4 [internal function]: Omeka_Db->__call('fetchAll', Array)
#5 /services2/webpages/util/m/u/
in /services2/webpages/util/m/u/ on line 333

Can someone please help in a way that a very inexperienced, basic user can comprehend? Your assistance is much appreciated!

That error is telling you that the database rejected the username and password you tried to use (in db.ini).

Double-check the entries in your db.ini file, and check with your host or sysadmin to make sure what the correct values are.

Thank you, John. I reset the password on the user and the MySQL databases, and I no longer get that error. Now I'm getting the much-talked-about error:

1.mod_rewrite is not enabled
Apache's mod_rewrite extension must be enabled for Omeka to work properly. Please enable mod_rewrite and try again.

My host said mod_rewrite is enabled. So I'm going through the .htaccess files and following the directions, but when it says to enter my "base directory", what exactly should I be entering? Can you give me an example of what that line should read? Would it be correct if I put:



Thanks again!

In general, the RewriteBase directive should be set to the portion of the URL after the domain name.

So, in your case, you'd probably want:

RewriteBase /omeka

Remember, there are also .htaccess files in the admin and (particularly important for this case) install directories.

The same idea applies for these, so in admin/.htaccess, you'd want:

RewriteBase /omeka/admin

And in install/.htaccess, you'd want:

RewriteBase /omeka/install

Thank you for your help! Not only did I get the install to work, but I made it through an upgrade, too (apparently was not installing the latest version).