Installation issue Omeka 2.0


I want to install Omeka 2.0 in my subdomain

I have checked and double checked that I followed all the installation steps correctly, and I did.

I got two different error messages:

First : Failed to execute command: which convert.

I then redid the install to make sure no files were missing when I transfered the Omeka directory on my server, now I'm getting this:

Internal Server Error

"The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request."

Can the issue be related to :


I would greatly appreciate some help because this is the fourth or fifth time I reinstall Omeka and it doesn't work.

The first problem you described, "Failed to execute command," is probably an issue with the proc_open function being disabled. You can check with your host to see if they have a way for you to enable it for your site.

The 500 error could be caused by a number of things, but since it only occurred after you tried reinstalling, I'd assume it's some issue that happened when you re-uploaded the Omeka files. Wiping everything out of that directory and starting over might help. Failing that, your server host should be able to look at logs (or show you how to look at logs) to see what's causing this error page.

Hello, thank you for your prompt reply!

I solved the 500 error message, it was only a question of permissions.

As for the proc_open enabling, I am using HostPapa and they are unable to do that. They are advising me to move my project to a VSP or dedicated server, but those are quite expensive.

So I was looking into changing webhost providers, but I insist that it be a Canadian one (I've had a look at the Omeka Hosting Suggestions page, are any of those Canadian?)

I was looking at and was wondering if it would be adapted for Omeka. Have you ever had any complaints by Omeka users in relation to that webhosting service ?

Thank you very much!

Can you ask your current host if they allow any of the PHP functions for calling shell commands?

I don't think I have any information on that host, or Canadian hosting in general. I would think you could ask them what kinds of restrictions they put on PHP, though.