installation error -- vague

I am installing Omeka 2.0.3 on Dreamhost, have provided what I believe to be accurate info in the db.ini file but get a very vague error message when I try to go to my omeka site: "Omeka has encountered an error."

I've triple-checked the details of my database info, and am not sure what else to try. Any suggestions?

Thanks! - Monica

Have you tried following the instructions on retrieving error messages?

Yes, I just removed the # sign in that line. Same error message.

Do I need to add a port number in db.ini? I was in a group of people doing this installation a couple of days ago and none of them put any port number in. They all successfully installed Omeka.

You generally don't need to set a port number.

It's strange that the error message setting didn't work for you. You can try an alternate method for enabling error message printing, though.

In the bootstrap.php file in the site root, add the following line right below the <?php that starts the file:

define('APPLICATION_ENV', 'development');