Install works but links off home page don't work

I've tried a couple of times now to get an installation of Omeka working.

Environment: Omeka 0.9.0, ubuntu 2.6.22-14-server
php5, mysql5 etc.

Install process works as expected, MySQL database gets created. Everything looks oK. I can load the site homepage (e.g., /omeka/index.php) but all the links off that page are broken and putting /admin/ after the home page URL doesn't work. I get this sort of error message:

The requested URL /omeka/admin/users/login was not found on this server.

Apache/2.2.4 (Ubuntu) PHP/5.2.3-1ubuntu6.3 Server at Port 80

If I click on Browse on the home page, I see my server's trying to resolve:

The .htaccess files are in the omeka top-level directory and in ./admin as indicated but clearly something's not right.

Anyone have a suggestion on where I might look? I do know that my rewrite module is loaded in Apache2

-- Wally

I also used the same configuration and had the very same problem....

I also have installed it on an ubuntu dedicated server and got the same problem. I don't know much about htacess file but the problem should be there ...

Ok, I've searched more and the problem (for me at least) was a problem with the configuration for the default site (/etc/apache2/sites-availables/default). In the virtualhost section, directory <Directory /home/syma/www/> I had to change "AllowOverride None" to "AllowOverride All"

Now it works, hope it helps.

Thanks for the fix, syma. Hope this helps, Wally. If not, just let us know. Our developer gang is at Code4Lib, but they should be able to help from the road.

Yes, this fixed it. Thanks syma.

This fix solved the problem on Debian unstable (Lenny) as well.

I'm getting this same problem.
I'm using godaddy as the shared host provider.

Cannot understand why with the new install none of the modules work, and I cannot get to the admin portion of the install.

When I type the admin portion, it sends me to:

with a page not found....

Any ideas?

Hi, try everything on this page and then let me know if it's still not fixed. Thanks

mod_rewrite is installed on the appache server and the htaccess files are in place.

Any other ideas?

Sorry, we just realized some of the material on the Troubleshooting page was mistakenly labeled. Did you also try this?

If installing mod_rewrite does not solve the problem, check that your Apache configuration allows .htaccess overrides. You will need the AllowOverides All directive in the appropriate place in httpd.conf.

I've come back to try again using the upgrade. Install went fine but I cannot access admin panel.
Mod_rewrite is installed.

This is on a shared hosting account where you do not have access to modify the conf files (they do not use httpd.conf - they use another one).

Has anyone had a problem installing and using this package on a shared host?

What next?

You'll have to edit whatever apache configuration file exists for your directory, which, depending on how GoDaddy works, may require you to have them do it for you. You said they don't use httpd.conf, but instead "use another one".. try editing that.

AllowOverride needs to be set to All when editing that file.

Good luck.

I just installed Omeka on a shared hosting account with GoDaddy, and this article helped:

I added the two lines of code below the .htaccess file in the omeka root directory, which told the server to use PHP 5 and not PHP 4 for the app.

AddHandler x-httpd-php5 .php
AddHandler x-httpd-php .php4

Thanks, Amanda.

I had some additional GoDaddy struggles and with a bit of help was able to get Omeka up and running. I thought I would share the fixes here for anyone else that runs into this trouble.

After adding amandafrench's fix for the php version I needed to add another bit to each of three .httaccess files.

So underneath the line

RewriteEngine on

I added
RewriteBase /
to the root .httaccess file

I added
RewriteBase /install/
to the /install .httaccess file

RewriteBase /admin/
to the /admin .httaccess file

Once I made those three changes it was good to go.