Install on Mac Mountain Lion

Hi y'all. So I need some help here installing this on a Mac running Mountain Lion. I just switched to Macs so I am still learning some of things so take that into account when helping.

Basically, I tried following the directions in this thread:

I was unsuccessful. I need to know what the easiest, most effective way of using it would be and essentially, step by step on how to install. I can't tell you exactly what didn't work with my installation. I installed Imagic and MAMP. MAMP connected and all that. When I clicked on the db.ini of Omeka, it opened a site saying there was an error. From there I got stuck. Ideally, I think I would like to start installation from scratch.

So if anyone is willing to give me some help, I would be most appreciative!

You probably don't need to start from scratch.

Have you tried to see what the error you're getting is? See Retrieving Error Messages on the documentation.

I did see that documentation, but honestly, it looks like an alien language and I couldn't figure out how to get it to show the error message. I don't believe I could find the .htaccess file in my Omeka file. I tried searching my mac for that, but it didn't find anything.

If there is an option in your file browser to "Show hidden files" or something like that, tell it to show those. That should let you see .htaccess in the top folder of omeka.

Then, even though it's an alien language, you just need to make the couple changes described on the retrieving error messages page.

Ok, so I was able to do that and got the error message:

"Your Omeka database configuration file has not been set up properly. Please edit the configuration and reload this page."

I understand that I need to configure it, but I can't figure out where to go to do that :(

Hello, so I was able to get everything installed and running except for 1 more hiccup. The Imagemagick isn't being recognized by Omeka. I installed it via Macports and set the IM directory path as "/opt/local/bin/" sans quotes. I got that from several other forums threads. But it doesn't work. It keeps saying fail. So what do I do?

This is unlikely to be very helpful, but I suggest not using MacPorts. When I originally tested Omeka on Snow Leopard, I used the instructions on this site to create a MAMP environment.

I have successfully used the directions on this site for Mountain Lion too, but have not tried installing Omeka.

To build ImageMagick for Snow Leopard, I followed these directions.

Also, I just did a quick test build of Imagemagick on Mountain Lion via

curl -O
tar -zxvf ImageMagick.tar.gz
cd ImageMagick-6.7.9-7
./configure --prefix=/usr/local
sudo make install
make check

It looked good to me. I even created the test logo.

/usr/local/bin/convert logo: logo.gif

Please note, this was after installing X11 following these directions:

Hope this helps, even if it isn't a MacPorts fix.

If you want to verify your path you could try:

which convert

I get:


so I would use /usr/local/bin

Hope this helps.

I'm having a lot of trouble installing ImageMagick on a Mac running 10.8.2. I tried MacPorts, I tried Brew, I tried their own installation, and I tried @fgertz' method above. Omeka is working fine, but not ImageMagick. I've done the error reporting stuff, but all I get, when I go to omeka/admin/settings, and enter /usr/local/bin/ is "fails". Even though terminal tells me /usr/local/bin/convert when I ask it "which convert"...
Any advice gratefully received.