Increasing maximum upload file size

I have just taken over support for a Red Hat web server that is running Omeka and there has been a request come through to increase the maximum file upload size. The current allowable size is 60MB and it has been requested to increase it to 70MB. Unfortunately I'm not sure exactly how to go about this. I come from a primarily Windows background, but have had some Linux experience. I have done some searching online and on these forums for any recommendations. There seems to be a common reference to making changes to the "post_max_size" and "upload_max_filesize" in the php.ini file, but these are currently set to only 8M and 2M respectively. Additionally this web server is hosting multiple websites so I don't want to make any changes that affect all hosted websites.

I have found the config.ini file (/var/www-hosted/<website>/omeka/application/config/config.ini) which does look like the correct location to make the required change, as it has a value called "upload.maxFileSize" which was set to 60M. I tried changing this to 70M and restarting the PHP service, but it had no effect. I also tried rebooting the server, thinking that this config file would be read with the changed value, but again it had no effect.

I would appreciate any assistance in enabling the change outlined above.

Are you sure that you're looking at the right php.ini, or that the settings aren't changed elsewhere?

Generally, Omeka does take its filesize restrictions from those set on PHP, post_max_size and upload_max_filesize. Omeka's setting upload.maxFileSize just lets you set a size that's more restrictive than what the PHP settings allow, it doesn't let you go beyond that.

Thanks for your response. The web server in question actually has 3 different instances of Omeka running for 3 different wikis. If I change the "post_max_size" and "upload_max_filesize" values in the /etc/php.ini file the other two instances change and the maximum file size changes on the "Add New Files" page, but the one I'm having a problem with doesn't. It appears that it's getting its "upload_max_filesize" value from somewhere else.

Any further thoughts would be much appreciated.

Each directory can have its own php.ini file that can override /etc/php.ini. I'd check for one in the directory of the instance that's misbehaving (and in each of the directories above it, if any)

Thanks for your suggestion. I have searched the whole server and can only find the one php.ini file (/etc/php.ini) There are a couple of other php.ini related files called php.ini-development and php.ini-production but neither of them contain any reference to maximum upload file sizes.

I did a search from the root of the omeka instance that I'm having the problem with for any files containing "upload_max", "upload.max" "max_file", maxFile", "setMaxFile", and a few other variations, which returned the following files:


None of those files set a specific vale for 'post_max_size' or 'upload_max_filesize'. They just seem to contain functions to calculate and return the maximum file size based on variable values.

Is there a way for Omeka to tell you where it's getting it's post_max_size from? How do I know it's pulling from /php.ini ?

Omeka doesn't really know where it gets those settings from, they're just read out from PHP.

If you're not sure where your PHP settings are, or which take precedence if you have several places where they can be set, you should probably check with your host. These things can be set up a few different ways.

I didn't find any way to tell where Omeka got its post_max_size from. Just had to look around. Finally tracked it down to a file in a subfolder of /etc/httpd/vhosts/(websitename). There was an entry in there for "php_value upload_max_filesize" and "php_value post_max_size". Also had to change the upload.maxFileSize value in the "/var/www-hosted/(websitename)/omeka/application/config.ini" file.
Hope that helps point you in the right direction.

In php.ini I changed:

but there seems to be some confusion about the omeka settings. Do I add this to .htaccess:
php_value upload_max_filesize xxM
php_value post_max_size xxM

or do I un-comment the /omeka/application/config/config.ini file's:
upload.maxFileSize = "10M"


I changed mine to the following with no problems.

upload.maxFileSize = "128M"