images not uploading consitantly

My website is at
Omeka site -

Q. Installation went perfect for 1.5.2, I have even uploaded and seen images. Then went back, and now it will not work. Why are images not uploading constantly?

My host is godaddy, Linux shared server.
Imagemagick is at /usr/bin and shows works.
PHP, Apache, MySQL all up-to-date.
it should be configurred right as it has worked.. sometimes... see the site.

I get the following error: Omeka has encountered an error. I have been able to sporadically uploaded and see image thumbs, then went back to work more and now it will not upload again.

Log file reads:

2012-07-29T00:05:32-04:00 WARN (4): Omeka_Storage_Adapter_Filesystem: Tried to delete missing file 'files/f04555af622f6d346fc1cb9cfc881fc0.jpg'.
2012-07-29T00:05:33-04:00 ERR (3): exception 'Omeka_File_Derivative_Exception' with message 'Something went wrong with image creation. Please notify an administrator.' in /home/content/54/7354954/html/collections/application/libraries/Omeka/File/Derivative/Image.php:189
Stack trace:
#0 /home/content/54/7354954/html/collections/application/libraries/Omeka/File/Derivative/Image.php(115): Omeka_File_Derivative_Image::createImage('/var/chroot/hom...', '200', 'square_thumbnai...')
#1 /home/content/54/7354954/html/collections/application/libraries/Omeka/File/Derivative/Image.php(222): Omeka_File_Derivative_Image::createDerivativeImages('/var/chroot/hom...')
#2 /home/content/54/7354954/html/collections/application/models/File.php(248): Omeka_File_Derivative_Image::createAll('/var/chroot/hom...', 'image/jpeg')

Please help as I would like to use this product. Thanks in advance for your help. The application looks perfect for my needs so I am quite excited, if only I can keep the image uploads working...


Is it specific images that always fail, or is it just that all images fail to upload at certain times?

You might want to check with GoDaddy to see if they've changed some setting or can look at server logs to see what's going wrong.

Thanks for reply John.
Godaddy has not upgraded anything in the last 10 days, my install is only 4 days old.

I can login as admin to continue with item creations (I have a few collections that I am populating). The image upload works great, when I finish the day's work I logout (a fine productive day). The next morning I logged back into admin to continue and everything but image uploads works. Could not get any image to upload. even created a few new items and tried images that had worked before, still not working, frustration brought me to call it a day, so logged out and went to bed.

Now today I logged in and it allowed me to upload an image. I worked for about an hour or so and then it suddenly stopped allowing image uploads. So I stopped and logged out to troubleshoot latter.

This is why I say "images not uploading constantly". I seams to works till reaching some-unknown point (attribute, limit, what-have you)causing it stop or prohibit any more image uploads for some unknown time-frame. This behavior has me guessing that in a couple days it should work again for a while. Sorry about the assumptions, but I have only a few days of exposure and a very limited knowledge base for the Omeka software.

Any Thoughts?

Again thanks in advance for the help.

Nothing comes to mind immediately.

Omeka itself doesn't have any quotas or limits on uploads within a time frame that you'd be hitting.

I still think it's some action or automatic process by your host that's messing things up, most likely. Perhaps they're changing or removing your permissions to write to the server's temp directory periodically?