Images not appearing

Hi - Probably a very dumb question, but here goes. I uploaded some images using the Dropbox but also through the items menu. They don't appear as images anywhere on the site -- only as links. What am I doing wrong?

Hi Beth,

What type of image files are they? Are they JPEG 2000s by any chance?


They're plain old jpgs... tried a whole bunch... some big, some small, doesn't seem to matter.

Does this happen for all your image files, or only a few? Sounds like you either haven't set your ImageMagic path correctly (or don't have ImageMagick on your server), or that the MIME types of the images aren't correct (or aren't being read correctly by Omeka.) If its happening to all your images, I suspect there's a problem with ImageMagick. Make sure the path to ImageMagick is present in Admin > Settings > General Settings, in the field "Path to Convert." You can determine this path by typing "which convert" on the command line if logged into your server through SSH. Or, you may have to ask your server admin or hosting service for this information. Hopefully your server has ImageMagick installed, or it can be installed for you; Its required for creating derivative images.

Yup, we think that's it too -- my brilliant husband just figured that out and is working on it now. :)

Thanks Jeremy!

Hmm, this sounds a bit like the problem I reported when using IE to directly add jpegs to records in admin.

Still a mystery.

I was having the same problem, and I for the same reason: the path to ImageMagic wasn't set. I've fixed it, but because it was missing all this time, all the images I've uploaded previously don't have thumbnails, etc. Is there a way to invoke those IM actions -- the ones that normally take place upon upload -- for all the images that have already been uploaded?

We've run into similar problems in the past where projects changed the default sizes of images after uploading files to their archives. I'll ask members of the dev team for any code we've jigged up for this, and pass it along.