I have updated my server to Omeka 2.1.2 and now am having a problem with the Imagemagik function.
Version 2.0.4 worked perfectly for the last 4 months but I now suffer the following -

Hitting the Test button in the settings menu produces "The ImageMagick directory path does not work". Attempting to upload a file will produce a working file in the "Original" files folder but the other file folders are empty. File and folder permissions all look OK.

The upgrade of my locally based virtual test machine works perfectly.

Any ideas what has gone wrong or suggestions as to how I diagnose it.

There's no change in how Omeka handles ImageMagick between 2.0 and 2.1.

Are you sure that something on your server hasn't changed, like permissions, the location or presence of the ImageMagick commands, or PHP settings?

Thanks for the reply John,

I realize that 2.0 and 2.1 are treated the same as my local test server upgraded OK. It's just my hosted system that has the problem.

The permissions, location and PHP settings look OK and have not changed as far as I know. However, this instance is hosted so I don't have full visibility of the whole system.

It seems strange that it partly works, in that it will upload the file, but not create the derived files.

I was hoping someone would say "ah with these symptoms, this is the problem". Alternatively, have you any idea how I diagnose the issue?

Got it!

I have just copied the Convert and Identify files again using the hosts control panel rather than using ftp. This fixed it. Not sure what was wrong but it seems to be all OK now.

Thanks for your help John.