ImageMagick settings


I've got a new installation, and I'm having trouble with images. Maybe someone can help?

When I try and upload an image file, I get "ImageMagick is not properly configured. Please check your settings and then try again."

I checked my settings in /admin/settings, and they're definitely correct, as far as imagemagick goes. That is, I've confirmed that my Path to Convert is "/usr/bin". I also tried /usr/bin/convert, to no avail.

So what am I doing wrong? Did I miss a step?

Thanks in advance.


Have you looked through the forums, because some other Omeka users have had some troubles with Image Magick? This string might be helpful:


Hi Sheila,

Thanks for replying. I've looked through several of those, but nothing I've tried yet has worked. For example, in that thread you link to, the suggestion to edit File.php doesn't apply since (I guess) I'm on a newer version of Omeka (the specified content wasn't in my File.php).

I can, however, confirm that imagemagick is installed, I can use convert from a shell, and 'which convert' returns '/usr/bin/convert'.

What version of ImageMagick do you have?

Here's what I get from 'convert -version':

Version: ImageMagick 6.4.9-6 2009-02-19 Q16
Copyright: Copyright (C) 1999-2009 ImageMagick Studio LLC

OK, I went ahead and tried the hack alluded to in this thread, and it works.

I just edited File.php, and set it to always return TRUE for the function checkForImageMagick. Seems to work fine.