ImageMagick Path

Hi Folks,
I upgrade to Omeka 1.3 from 1.0 this morning. The upgrade went smooth, until I hit the ImageMagick Dir Path. I entered the correct path: /usr/bin/convert, hit save setting, then test. The test failed. I confirmed ImageMagick was installed on the server via command line - /usr/bin/convert -version. It returned the running version ImageMagik. Host: Media Temple, plan Grid Service. Any ideas?

The ImageMagick path only wants the path to the directory that contains convert.

In your case, it looks like you want to put /usr/bin in that field.

Hi John -
No luck. Tried your suggestion. According to Media Temple the path is /usr/bin/convert
(GS Service)

I remember dealing with this issue on a earlier version, but I can't remember what I did to get it working. Is there any files that I should be looking at?

With the path set to /usr/bin, have you tried uploading an image to see if the thumbnails have been generated?

Some odd versions of ImageMagick don't respond well to Omeka's ImageMagick test.

Here's the version of IM our server is running:

/usr/bin/convert -versionVersion: ImageMagick 6.2.4 09/16/06 Q16
Copyright: Copyright (C) 1999-2005 ImageMagick Studio LLC

Tried changing the the /usr/bin and no luck.

Here's what I did to get it working. Its far from perfect... I commented line number 75 out and add hard code the path.
File path: application/libraries/File/Derivative/Image.php

Hard code the path:
// $rawPath = get_option('path_to_convert');
$rawPath = '/usr/bin/convert/'; Did you try adding a '/' to the end of the value you entered? That seems to be the only difference between what you first post used, and what your last post used?

hey mountaindog am reawakening your thread!!! have you had any issues (solutions) with recent versions of omeka and mediatemple?

I use the version 2.1.1. According to the administrator of our server, the directory path of imagemagick is /usr/local/bin/convert. But, it does not work. When I set the path to /usr/bin, Files are uploaded. However, thumbnails are not generated ( what's wrong?

Just to make sure, when you test both /usr/local/bin and /usr/bin on the Settings page, there's a message that neither one works?

When I set to /usr/local/bin, it works well. Thank you

I have been trying to figure out this problem for months. Any help would be appreciated. I'm on MediaTemple. Updated to the newest version of Omeka today, but still getting the same error concerning ImageMagick and cannot add any new items. Here is the dump from the log:

2014-08-25T16:30:00-07:00 WARN (4): Omeka_Storage_Adapter_Filesystem: Tried to delete missing file 'original/0d8a366b06f7a9cae55b172a922814b4.jpg'.
2014-08-25T16:30:00-07:00 ERR (3): exception 'Omeka_File_Derivative_Exception' with message 'ImageMagick is not properly configured: invalid directory given for the ImageMagick command!' in /nfs/c08/h02/mnt/119639/domains/
Stack trace:
#0 /nfs/c08/h02/mnt/119639/domains/ Omeka_File_Derivative_Strategy_ExternalImageMagick->_getConvertPath()
#1 /nfs/c08/h02/mnt/119639/domains/ Omeka_File_Derivative_Strategy_ExternalImageMagick->createImage('/tmp/0d8a366b06...', '/tmp/fullsize_0...', 'fullsize', 800, 'image/jpeg')
#2 /nfs/c08/h02/mnt/119639/domains/ Omeka_File_Derivative_Creator->create('/tmp/0d8a366b06...', '0d8a366b06f7a9c...', 'image/jpeg')
#3 /nfs/c08/h02/mnt/119639/domains/ File->createDerivatives()
#4 /nfs/c08/h02/mnt/119639/domains/ Job_FileProcessUpload->perform()
#5 /nfs/c08/h02/mnt/119639/domains/ Omeka_Job_Dispatcher_Adapter_Synchronous->send('{"className":"J...', Array)
#6 /nfs/c08/h02/mnt/119639/domains/ Omeka_Job_Dispatcher_Default->send('Job_FileProcess...', Array)
#7 [internal function]: File->afterSave(Array)
#8 /nfs/c08/h02/mnt/119639/domains/ call_user_func(Array, Array)
#9 /nfs/c08/h02/mnt/119639/domains/ Omeka_Record_AbstractRecord->runCallbacks('afterSave', Array)
#10 /nfs/c08/h02/mnt/119639/domains/ Omeka_Record_AbstractRecord->save()
#11 /nfs/c08/h02/mnt/119639/domains/ Item->saveFiles()
#12 [internal function]: Item->afterSave(Array)
#13 /nfs/c08/h02/mnt/119639/domains/ call_user_func(Array, Array)
#14 /nfs/c08/h02/mnt/119639/domains/ Omeka_Record_AbstractRecord->runCallbacks('afterSave', Array)
#15 /nfs/c08/h02/mnt/119639/domains/ Omeka_Record_AbstractRecord->save(false)
#16 /nfs/c08/h02/mnt/119639/domains/ Omeka_Controller_AbstractActionController->addAction()
#17 /nfs/c08/h02/mnt/119639/domains/ ItemsController->addAction()
#18 /nfs/c08/h02/mnt/119639/domains/ Zend_Controller_Action->dispatch('addAction')
#19 /nfs/c08/h02/mnt/119639/domains/ Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
#20 /nfs/c08/h02/mnt/119639/domains/ Zend_Controller_Front->dispatch()
#21 /nfs/c08/h02/mnt/119639/domains/ Zend_Application_Bootstrap_Bootstrap->run()
#22 /nfs/c08/h02/mnt/119639/domains/ Zend_Application->run()
#23 /nfs/c08/h02/mnt/119639/domains/ Omeka_Application->run()
#24 {main}

What's the result when you test the ImageMagick path in Admin->Settings?

How to generate thumbnails with video files?


If you have a new question, please open a new thread for it. This one is only for questions about the ImageMagick path setting (and is overdue to be closed as it's over 3 years old).

Hai where i need to set imagemagick path in omeka. For my file its there in /usr/bin/convert -version.
But image is not dsiplay when adding an items. So where i need to set the imagemagick path. Anyone can help me with this?
Thanks in advance

The ImageMagick path can be entered in General Settings.

For more information on managing media see: and for advanced information of thumbnail configuration:

Thanks mebrett. But i reinstall omeka in my system. Now its working.