ImageMagick Install

For some reason Omeka had problems with an install of ImageMagick using MacPorts onto a Mac with OSX Lion. It may be because it installed the distribution file into /opt/local. I could not get Omeka to work no matter what directory path was specified.

To get it to work I downloaded ImageMagick 6.7.1 from Double clicked the tar file to decompress it. Then I manually dragged and dropped the distribution files into their proper folders at /usr/local/. After specifying the ImageMagick path as /usr/local/bin and clicking the TEST button on the Omeka General Setting page I got "Works" and adding a photo item also worked.

Glad that you found a solution that works for you.

In my personal experience, an install of ImageMagick from MacPorts works fine with Omeka, as long as you give the correct path in the Site Settings (/opt/local/bin). I'll admit that I haven't had the opportunity to try this out on Lion, but I'd be surprised if it didn't work.

(On a side note, apologies if this thread seemed to just disappear. Our forum software marked it as spam for some reason.)

I'm just running into this too. After installing ImageMagick 6.7.1-7 2011-08-27 Q16 with MacPorts yesterday on OSX Lion I can use convert just fine from the command line but not from Omeka, specifying /opt/local/bin/. But it's definitely there:

-rwxr-xr-x 1 root admin 9268 Aug 27 21:42 /opt/local/bin/convert

I'm not sure what's going on here, and I don't have access to a Lion machine to do any testing.

There's nothing obviously wrong or different in the output you posted, but there must be some other wrinkle that's causing this.

It's possible that there's some bug in that particular version from MacPorts, rather than anything Lion-specific. I see that there already appears to be a new version (6.7.2).

I updated to the current MacPorts but no luck. XAMPP ( however had no issues with Omeka or with the MacPorts installed ImageMagick and so I'm going to try using this as an alternative to MAMP in the future.

Here is a problem that may be solved soon with updates, but the Mac Lion may be missing a file that ImageMagick uses:

Try to run convert from the Terminal and it will fail and complain about this. Get the file from an older system or here:

Hello, new user here checking out Omeka on a Mac with Mountain Lion 10.8.5 and MAMP. Using ImageMagick installed with the HomeBrew package manager in /usr/local/Cellar/imagemagick/6.8.7-0/bin/, I was getting error: The ImageMagick directory path does not work even when it was added to my PATH.

ImageMagick indeed works in this location, at least with a number of Ruby (programming language) CMS programs I've used. I tried a number of things, including reinstalling XQuartz and ImageMagick (through HomeBrew) dice.

Finally, I got a new binary of ImageMagick installed from

I put it in opt/ImageMagick/bin/ and Omeka found it OK.