Image Upload Error

Very simple problem: Trying to add a 'still image' to the archive, going through the whole three step process only to get the message:

"Something went wrong with image creation. Please notify an administrator."

I am fairly sure that my ImageMagick is up and running properly. Any ideas on what the problem is?

Could you let us know what version of Omeka you're running? And have you tried multiple files, of different types and sizes? If you're on a shared commercial webhost, the company name may help as well.

My hunch is that it's one of these:
1) the sizes of the file you're uploading exceeds your server's $_POST limits (this will vary)
2) problems with metadata extraction (sometimes related to server tweaks, removing --exif-enable module)
3) an incorrect path set to imagemagick

It's version 0.9.2. I am hosting it with Godaddy. Forgive my ignorance, what difference does the hosting make?

Also, is there an easy way for me to locate imagemagick? I think your hunch about the incorrect path is a great guess, and I don't know quite how to set the correct one.

We're aware of a few shared hosts that have unique server adjustments by disabling standard apache modules -- this sometimes causes problems running Omeka. As a result, we often suggest Dreamhost as a reliable and consistent shared hosting option. I think GoDaddy should be fine -- it's infrequent that we run into those problems.

I Googled and found info on GoDaddy's site ( that says ImageMagick is located at /usr/local/bin/ Let us know if that works.


Thanks so much. That has helped but now I am facing a new error: ImageMagick is not properly configured. Please check your settings and then try again.

Any help on this?


It's possible that you need to follow the advice in this posting

which advises removing . -version from line 374 of the application/models/File.php file.

In addition the Path to Convert should be set to /usr/local/bin/convert.


Mine is hosted with GoDaddy, and changing the path from /usr/bin to /usr/local/bin worked like a charm. Thanks.