Image Magick Directory Path

Good Evening,

I have recently upgraded to version 2.1.3 and am having trouble with uploading items to the database, I keep receiving the message "Omeka has encountered an error." Myself and my colleague have narrowed down the issue being with Image Magick. Would anyone happen to know the proper directory path for this version? Currently, it says "/usr/bin/", will this have to change? I am not as code-savvy as I would like to be so my apologies if I sound redundant. Any help that can be provided is greatly appreciated!


There might be more information in the rest of the error message, especially if you turn on error reporting following the info in the link that's in the message.

ImageMagick settings are server-specific, so the first thing to try is to go to the Settings page and at the bottom test the path to Image Magick.

If the path works, then it's either something besides Image Magick path, or something more complicated. If it doesn't work, then the hosting service or server admin should be able to give you the correct path, if it is available.

Thank you for your help. The path that is currently on my settings page is /usr/bin/ and this does not work when I test it. I have tried looking through the server to see where the error is occurring but I do not really know much about coding so unfortunately I do not know what to look for and I do not think (or know if) the correct path is available.

I've located the creator.php file by going through the files "libraries/omeka/file/derivative/image/creator" but not sure if this is the right place to look. I do not have the best support on site for solving this issue so I have to consult this forum.

Do you recommend any other sites or forums that can explain how to solve this issue in the easiest way possible? For someone such as myself with little to no coding experience, I find it difficult to achieve the simplest of tasks in this field sometimes. Thanks for bearing with my tirade!

No worries. If we're lucky we won't have to dive too deeply into coding stuff!

Since that path doesn't work, I'd ask your server hosting company or server admin what the correct path should be. It's likely that that's the only thing for us to figure out.


I had another look at the upgrading tips you posted a few weeks particular "files/ (for versions below 2.0, the folder is instead named archive/)
If you are upgrading from 1.x to 2.x rename archive to files, and rename the files/files in the directory you just renamed to files/original"

Currently, the path is Omeka/archive/archive/files" ... should this change? If so, will this help solve the issue or no?

Hi, I have no informatics background knowledge whatsoever. So, at the risk of sounding stupid I want to ask some questions. First thing to know: I run omeka 2.1.4 on MAMP 3.0.2 on a Macbook.

I wanted to activate ImageMagick in my omeka-site. I was about to download ImageMagick 6.8.9-3, but then I noticed there were already two instances of ImageMagick in two places in one and the same MAMP (or I believed there were): "MAMP>Library>lib> ImageMagick-6.8.7" and also in "MAMP>Library>etc>ImageMagick-6".

Now, when I wanted to set the path to ImageMagick (at the bottom of the settings page of omeka), I wrote: "../Library/lib/ImageMagick-6.8.7". When I tested that path, I received the message: "The ImageMagick directory path doesn't work". So, I deleted ".../Library/lib/ImageMagick-6.8.7" and I wrote: "../Library/etc/ImageMagick-6" instead, but I received the same error message.

My questions now are:
1) How do I have to set the path to ImageMagick correctly?
2) Are the ImageMagick-6.8.7 and ImageMagick-6 in MAMP 3.0.2 adequate, or should I download and install ImageMagick (version 6.8.9-3, as that is the latest version) from And suppose I have to do that, is it prerequisite to install MacPorts first, in order to facilitate the installation of ImageMagick 6.8.9-3? If someone could help me, please do!


this is the path